Weaknesses of type CWE-20

5,845 results

Validação inadequada de entrada

O software recebe dados do usuário ou de fontes externas, mas não verifica ou verifica de forma incompleta se esses dados têm as propriedades necessárias para processar com segurança. Isso permite que entradas malformadas, maliciosas ou inesperadas passem por controles e causem comportamentos indevidos — desde crashes até injeção de código.

Example

Uma aplicação web recebe um parâmetro numérico via GET, mas não valida se é realmente um número inteiro válido antes de usá-lo em uma consulta SQL. Um atacante envia um valor com caracteres especiais (ex: `1' OR '1'='1`), conseguindo injetar código SQL direto no banco de dados.

How to mitigate

Implemente validação rigorosa na entrada: defina o tipo, formato, comprimento e intervalo esperados; rejeite tudo que não se encaixe. Use listas de caracteres permitidos ('whitelist'), escape de dados para o contexto específico (SQL, HTML, URL) e bibliotecas de validação consolidadas. Nunca confie em dados do cliente.

CVE-2022-24861CRITICALRemote Code Execution in DatabasirEPSS 3.0%CVE-2016-9219—A vulnerability with IPv6 UDP ingress packet processing in Cisco Wireless LAN Controller (WLC) Software could allow an unauthenticated, remoEPSS 3.0%CVE-2021-26622CRITICALGenian NAC remote code execution vulnerabilityEPSS 3.0%CVE-2018-0264—A vulnerability in the Cisco WebEx Network Recording Player for Advanced Recording Format (ARF) files could allow an unauthenticated, remoteEPSS 3.0%CVE-2022-34916—Improper Input Validation (JNDI Injection) in JMSMessageConsumerEPSS 3.0%CVE-2021-0158MEDIUMImproper input validation in the BIOS firmware for some Intel(R) Processors may allow a privileged user to potentially enable escalation of EPSS 3.0%CVE-2022-32786MEDIUMAn issue in the handling of environment variables was addressed with improved validation. This issue is fixed in Security Update 2022-005 CaEPSS 3.0%CVE-2018-0349—A vulnerability in the Cisco SD-WAN Solution could allow an authenticated, remote attacker to overwrite arbitrary files on the underlying opEPSS 3.0%CVE-2017-7466HIGHAnsible before version 2.3 has an input validation vulnerability in the handling of data sent from client systems. An attacker with control EPSS 3.0%CVE-2020-10738HIGHA flaw was found in Moodle versions 3.8 before 3.8.3, 3.7 before 3.7.6, 3.6 before 3.6.10, 3.5 before 3.5.12 and earlier unsupported versionEPSS 3.0%CVE-2023-36566MEDIUMMicrosoft Common Data Model SDK Denial of Service VulnerabilityEPSS 3.0%CVE-2017-3825—A vulnerability in the ICMP ingress packet processing of Cisco TelePresence Collaboration Endpoint (CE) Software could allow an unauthenticaEPSS 3.0%CVE-2021-42114CRITICALScalable Rowhammering In the Frequency Domain to Bypass TRR Mitigations On Modern DDR4/LPDDR4X DevicesEPSS 3.0%CVE-2025-34113HIGHTiki Wiki CMS Authenticated Command Injection in Calendar ModuleEPSS 3.0%CVE-2025-34161CRITICALCoolify Git Repository Field Command Injection in Project Deployment WorkflowEPSS 3.0%CVE-2018-0345—A vulnerability in the configuration and management database of the Cisco SD-WAN Solution could allow an authenticated, remote attacker to eEPSS 3.0%CVE-2022-26781CRITICALMultiple improper input validation vulnerabilities exists in the libnvram.so nvram_import functionality of InHand Networks InRouter302 V3.5.EPSS 2.9%CVE-2021-35223HIGHExecute Command Function Allows Remote Code Execution (RCE)VulnerabilityEPSS 2.9%CVE-2019-1687MEDIUMCisco Adaptive Security Appliance Software and Firepower Threat Defense Software TCP Proxy Denial of Service VulnerabilityEPSS 2.9%CVE-2020-7071MEDIUMFILTER_VALIDATE_URL accepts URLs with invalid userinfoEPSS 2.9%