Falhas do tipo CWE-494

210 resultados

Elevação de privilégio

A aplicação não valida corretamente permissões ou contexto de segurança, permitindo que um usuário com privilégios baixos execute ações reservadas a administradores ou usuários com acesso mais elevado. É perigoso porque quebra o modelo de controle de acesso e expõe funcionalidades críticas.

Exemplo

Um usuário comum consegue acessar a API de administração porque o servidor valida apenas a presença de um token válido, ignorando o campo de 'role' contido nele; ou um programa SUID não revoga permissões root antes de executar código fornecido pelo usuário, permitindo leitura de arquivos sensíveis.

Como mitigar

Implemente verificação rigorosa de permissões em toda ação sensível (autorização não apenas autenticação), use listas de controle de acesso (ACL) explícitas, aplique princípio do menor privilégio e audite chamadas privilegiadas. Teste com usuários em papéis baixos para confirmar bloqueios.

CVE-2025-11182HIGHFile Download in GTONE ChangeFlowEPSS 0.4%CVE-2025-56513CRITICALNiceHash QuickMiner 6.12.0 perform software updates over HTTP without validating digital signatures or hash checks. An attacker capable of iEPSS 0.4%CVE-2019-10240—Eclipse hawkBit versions prior to 0.3.0M2 resolved Maven build artifacts for the Vaadin based UI over HTTP instead of HTTPS. Any of these deEPSS 0.4%CVE-2019-10248—Eclipse Vorto versions prior to 0.11 resolved Maven build artifacts for the Xtext project over HTTP instead of HTTPS. Any of these dependentEPSS 0.4%CVE-2022-46423HIGHAn exploitable firmware modification vulnerability was discovered on the Netgear WNR2000v1 router. An attacker can conduct a MITM (Man-in-thEPSS 0.4%CVE-2026-30612CRITICALAn issue in Time4 Popcorn for Windows <= 6.2.1.18 and Time4Popcorn for MacOS <= 6.2.1.17 and Time4Popcorn for Android <= 3.5.0.173 allows a EPSS 0.4%CVE-2023-37864HIGHPHOENIX CONTACT: WP 6xxx Web panels prone to download code without integrity checkEPSS 0.4%CVE-2026-66398CRITICALphpMyFAQ before 4.1.6 Remote Code Execution via Configuration APIEPSS 0.4%CVE-2026-65081HIGHNVIDIA NemoClaw for Linux contains a vulnerability in its installation process, where an attacker could cause execution of untrusted code. AEPSS 0.4%CVE-2025-27593CRITICALRCE due to Device DriverEPSS 0.4%CVE-2019-14845MEDIUMA vulnerability was found in OpenShift builds, versions 4.1 up to 4.3. Builds that extract source from a container image, bypass the TLS hosEPSS 0.4%CVE-2026-40066HIGHAnviz Products Download of Code Without Integrity CheckEPSS 0.4%CVE-2025-28236CRITICALNautel VX Series transmitters VX SW v6.4.0 and below was discovered to contain a remote code execution (RCE) vulnerability in the firmware uEPSS 0.4%CVE-2019-19166HIGHTobesoft XPlatform Arbitrary File Execution VulnerabilityEPSS 0.4%CVE-2023-27574—ShadowsocksX-NG 1.10.0 signs with com.apple.security.get-task-allow entitlements because of CODE_SIGNING_INJECT_BASE_ENTITLEMENTS.EPSS 0.4%CVE-2022-24117CRITICALCertain General Electric Renewable Energy products download firmware without an integrity check. This affects iNET and iNET II before 8.3.0,EPSS 0.4%CVE-2022-46430MEDIUMTP-Link TL-WR740N V1 and V2 v3.12.4 and earlier allows authenticated attackers to execute arbitrary code or cause a Denial of Service (DoS) EPSS 0.4%CVE-2022-46428MEDIUMTP-Link TL-WR1043ND V1 3.13.15 and earlier allows authenticated attackers to execute arbitrary code or cause a Denial of Service (DoS) via uEPSS 0.4%CVE-2025-14265CRITICALImproper server-side validation in ScreenConnect extension frameworkEPSS 0.4%CVE-2026-48046CRITICALStreambert Vulnerable to Remote Code Execution (RCE) via Unvalidated Auto-Updater IPC HandlerEPSS 0.4%