Falhas do tipo CWE-79

30.295 resultados

Injeção de Script entre Sites (XSS)

Ocorre quando a aplicação insere dados não validados do usuário diretamente em páginas HTML enviadas ao navegador, permitindo que atacantes injetem código JavaScript malicioso. O navegador executa esse script com os mesmos privilégios da sessão legítima, comprometendo dados da vítima ou sua conta.

Exemplo

Um formulário de busca que exibe o termo digitado na página sem sanitização: se você buscar por '<script>alert(1)</script>', esse script será executado no navegador de quem abrir o resultado. Um atacante pode roubar cookies de sessão ou redirecionar para um site falso.

Como mitigar

Valide e escape todos os dados do usuário antes de renderizar em HTML (use funções nativas como textContent em vez de innerHTML). Para entrada de dados, liste o que é permitido (whitelist); para saída, contextualize o escape (HTML, JavaScript, URL). Use Content Security Policy (CSP) como camada adicional para restringir execução de scripts inline.

CVE-2024-49259MEDIUMWordPress Primary Addon for Elementor plugin <= 1.5.8 - Cross Site Scripting (XSS) vulnerabilityEPSS 0.3%CVE-2025-26998MEDIUMWordPress SKT Blocks – Gutenberg based Page Builder plugin <= 1.8 - Cross Site Scripting (XSS) vulnerabilityEPSS 0.3%CVE-2025-31058HIGHWordPress Revolution Video Player plugin <= 2.9.2 - Reflected Cross Site Scripting (XSS) vulnerabilityEPSS 0.3%CVE-2025-31061HIGHWordPress Wishlist plugin <= 2.1.0 - Reflected Cross Site Scripting (XSS) vulnerabilityEPSS 0.3%CVE-2026-0735MEDIUMUser Language Switch <= 1.6.10 - Authenticated (Administrator+) Stored Cross-Site Scripting via 'tab_color_picker_language_switch' ParameterEPSS 0.3%CVE-2025-53500MEDIUMStored XSS in MassEditRegexEPSS 0.3%CVE-2025-31055HIGHWordPress Electrician - Electrical Service WordPress theme <= 1.0 - Cross Site Scripting (XSS) VulnerabilityEPSS 0.3%CVE-2025-47487HIGHWordPress MC Woocommerce Wishlist plugin <= 1.9.1 - Cross Site Scripting (XSS) VulnerabilityEPSS 0.3%CVE-2024-44046MEDIUMWordPress Themify plugin <= 1.5.1 - Cross Site Scripting (XSS) vulnerabilityEPSS 0.3%CVE-2024-49702MEDIUMWordPress myCred Elementor plugin <= 1.2.6 - Cross Site Scripting (XSS) vulnerabilityEPSS 0.3%CVE-2026-82546MEDIUMApache Roller: Stored cross-site scripting through incoming Trackback linksEPSS 0.3%CVE-2026-31833MEDIUMUmbraco has Stored XSS in UFM Rendering Pipeline via Permissive DOMPurify Attribute FilteringEPSS 0.3%CVE-2024-43967MEDIUMWordPress WP Testimonial Widget plugin <= 3.1 - Cross Site Scripting (XSS) vulnerabilityEPSS 0.3%CVE-2026-18197MEDIUMImproper neutralization of input during web page generation ('cross-site scripting') vulnerability in Link Library allows Cross-Site ScriptiEPSS 0.3%CVE-2025-31057HIGHWordPress Universal Video Player plugin <= 1.4.0 - Reflected Cross Site Scripting (XSS) vulnerabilityEPSS 0.3%CVE-2026-88905HIGHKeyWord Collector <= 1.4 - Unauthenticated Stored XSS and Settings Update via WPKeyWordSettingsEPSS 0.3%CVE-2026-30570MEDIUMA Reflected Cross-Site Scripting (XSS) vulnerability exists in SourceCodester Sales and Inventory System 1.0 in the view_sales.php file via EPSS 0.3%CVE-2024-13362MEDIUMFreemius <= 2.10.1 - Reflected DOM-Based Cross-Site Scripting via url ParameterEPSS 0.3%CVE-2025-49336MEDIUMWordPress Pondol BBS plugin <= 1.1.8.4 - Cross Site Scripting (XSS) vulnerabilityEPSS 0.3%CVE-2025-30955HIGHWordPress ListingEasy theme <= 1.9.2 - Reflected Cross Site Scripting (XSS) vulnerabilityEPSS 0.3%