Falhas do tipo CWE-79

30.299 resultados

Injeção de Script entre Sites (XSS)

Ocorre quando a aplicação insere dados não validados do usuário diretamente em páginas HTML enviadas ao navegador, permitindo que atacantes injetem código JavaScript malicioso. O navegador executa esse script com os mesmos privilégios da sessão legítima, comprometendo dados da vítima ou sua conta.

Exemplo

Um formulário de busca que exibe o termo digitado na página sem sanitização: se você buscar por '<script>alert(1)</script>', esse script será executado no navegador de quem abrir o resultado. Um atacante pode roubar cookies de sessão ou redirecionar para um site falso.

Como mitigar

Valide e escape todos os dados do usuário antes de renderizar em HTML (use funções nativas como textContent em vez de innerHTML). Para entrada de dados, liste o que é permitido (whitelist); para saída, contextualize o escape (HTML, JavaScript, URL). Use Content Security Policy (CSP) como camada adicional para restringir execução de scripts inline.

CVE-2025-48240MEDIUMWordPress Cost of Goods for WooCommerce plugin <= 3.7.0 - Cross Site Scripting (XSS) VulnerabilityEPSS 0.3%CVE-2024-54207MEDIUMWordPress WordPress Auction Plugin plugin <= 3.7 - Cross Site Scripting (XSS) vulnerabilityEPSS 0.3%CVE-2025-48235MEDIUMWordPress WP Image Mask plugin <= 3.1.2 - Cross Site Scripting (XSS) VulnerabilityEPSS 0.3%CVE-2025-60967HIGHCross Site Scripting (XSS) vulnerability in EndRun Technologies Sonoma D12 Network Time Server (GPS) F/W 6010-0076-000 Ver 4.00 allows attacEPSS 0.3%CVE-2019-25399MEDIUMIPFire 2.21 Core Update 127 Stored XSS via extrahd.cgiEPSS 0.3%CVE-2025-48369MEDIUMGroupOffice vulnerable to Stored XSS in Tasks Comment SectionEPSS 0.3%CVE-2024-38703MEDIUMWordPress WP Event Aggregator plugin <= 1.7.9 - Cross Site Scripting (XSS) vulnerabilityEPSS 0.3%CVE-2025-48258MEDIUMWordPress Mega Menu Block plugin <= 1.0.6 - Cross Site Scripting (XSS) VulnerabilityEPSS 0.3%CVE-2024-0640MEDIUMStored XSS in chatwoot/chatwootEPSS 0.3%CVE-2024-56246MEDIUMWordPress Nexter Blocks plugin <= 4.0.4 - Cross Site Scripting (XSS) vulnerabilityEPSS 0.3%CVE-2025-49311MEDIUMWordPress The Events Calendar Countdown Addon plugin <= 1.4.9 - Cross Site Scripting (XSS) VulnerabilityEPSS 0.3%CVE-2024-30192MEDIUMWordPress Pinterest Plugin <= 1.8.2 - Cross Site Scripting (XSS)EPSS 0.3%CVE-2026-8117MEDIUMSourceCodester Pizzafy Ecommerce System index.php cross site scriptingEPSS 0.3%CVE-2025-48248MEDIUMWordPress Sitewide Discount for WooCommerce: Apply Discount to All Products plugin <= 2.2.1 - Cross Site Scripting (XSS) VulnerabilityEPSS 0.3%CVE-2026-31860MEDIUMUnhead has a XSS bypass in `useHeadSafe` via attribute name injection and case-sensitive protocol checkEPSS 0.3%CVE-2026-7011MEDIUMMaxSite CMS Antispam Plugin plugin_antispam cross site scriptingEPSS 0.3%CVE-2025-32180MEDIUMWordPress Product Carousel For WooCommerce – WoorouSell plugin <= 1.1.0 - Cross Site Scripting (XSS) vulnerabilityEPSS 0.3%CVE-2025-31587MEDIUMWordPress Elfsight Testimonials Slider plugin <= 1.0.1 - Cross Site Scripting (XSS) vulnerabilityEPSS 0.3%CVE-2025-15056MEDIUMQuill 2.0.3 - Lack of data validation in HTML export allowing XSSEPSS 0.3%CVE-2024-50469MEDIUMWordPress Textboxes plugin <= 0.1.3.1 - Cross Site Scripting (XSS) vulnerabilityEPSS 0.3%