Falhas do tipo CWE-79

30.300 resultados

Injeção de Script entre Sites (XSS)

Ocorre quando a aplicação insere dados não validados do usuário diretamente em páginas HTML enviadas ao navegador, permitindo que atacantes injetem código JavaScript malicioso. O navegador executa esse script com os mesmos privilégios da sessão legítima, comprometendo dados da vítima ou sua conta.

Exemplo

Um formulário de busca que exibe o termo digitado na página sem sanitização: se você buscar por '<script>alert(1)</script>', esse script será executado no navegador de quem abrir o resultado. Um atacante pode roubar cookies de sessão ou redirecionar para um site falso.

Como mitigar

Valide e escape todos os dados do usuário antes de renderizar em HTML (use funções nativas como textContent em vez de innerHTML). Para entrada de dados, liste o que é permitido (whitelist); para saída, contextualize o escape (HTML, JavaScript, URL). Use Content Security Policy (CSP) como camada adicional para restringir execução de scripts inline.

CVE-2026-2932MEDIUMYiFang CMS Extended Management D_adPosition.php update cross site scriptingEPSS 0.3%CVE-2024-50460MEDIUMWordPress Firelight Lightbox plugin <= 2.3.3 - Cross Site Scripting (XSS) vulnerabilityEPSS 0.3%CVE-2024-34575MEDIUMWordPress DethemeKit For Elementor plugin <= 2.1.2 - Cross Site Scripting (XSS) vulnerabilityEPSS 0.3%CVE-2026-48258MEDIUMAdobe Experience Manager | Cross-site Scripting (DOM-based XSS) (CWE-79)EPSS 0.3%CVE-2024-38784MEDIUMWordPress Livemesh Addons for Beaver Builder plugin <= 3.6.1 - Cross Site Scripting (XSS) vulnerabilityEPSS 0.3%CVE-2024-37949MEDIUMWordPress Responsive Mobile theme <= 1.15.1 - Cross Site Scripting (XSS) vulnerabilityEPSS 0.3%CVE-2024-47627MEDIUMWordPress WP Travel Gutenberg Blocks plugin <= 3.6.0 - Cross Site Scripting (XSS) vulnerabilityEPSS 0.3%CVE-2024-51685MEDIUMWordPress Accordion title for Elementor plugin <= 1.2.1 - Cross Site Scripting (XSS) vulnerabilityEPSS 0.3%CVE-2024-41774MEDIUMIBM Common Licensing cross-site scriptingEPSS 0.3%CVE-2024-47629MEDIUMWordPress Ultimate Store Kit Elementor Addons plugin <= 2.0.5 - Cross Site Scripting (XSS) vulnerabilityEPSS 0.3%CVE-2025-28978HIGHWordPress SB Breadcrumbs plugin <= 1.0 - Reflected Cross Site Scripting (XSS) vulnerabilityEPSS 0.3%CVE-2024-5521MEDIUMCross-Site Scripting stored in Alkacon OpenCMSEPSS 0.3%CVE-2025-14626MEDIUMQR Code for WooCommerce order emails, PDF invoices, packing slips <= 1.9.42 - Authenticated (Contributor+) Cross-Site Scripting via Shortcode AttributesEPSS 0.3%CVE-2025-14796MEDIUMMy Album Gallery <= 1.0.4 - Authenticated (Author+) Stored Cross-Site Scripting via Image TitleEPSS 0.3%CVE-2025-65592MEDIUMnopCommerce 4.90.0 is vulnerable to Cross Site Scripting (XSS) in the product management functionality. Malicious payloads inserted into theEPSS 0.3%CVE-2024-38720MEDIUMWordPress EazyDocs plugin <= 2.5.0 - Cross Site Scripting (XSS) vulnerabilityEPSS 0.3%CVE-2024-49265MEDIUMWordPress Booking.com Banner Creator plugin <= 1.4.6 - Cross Site Scripting (XSS) vulnerabilityEPSS 0.3%CVE-2024-43920MEDIUMWordPress Gutenverse – Gutenberg Blocks – Page Builder for Site Editor plugin <= 1.9.4 - Cross Site Scripting (XSS) vulnerabilityEPSS 0.3%CVE-2026-48271MEDIUMAdobe Experience Manager | Cross-site Scripting (DOM-based XSS) (CWE-79)EPSS 0.3%CVE-2025-39488HIGHWordPress MagOne theme <= 8.8 - Reflected Cross Site Scripting (XSS) vulnerabilityEPSS 0.3%