Falhas do tipo CWE-79

30.463 resultados

Injeção de Script entre Sites (XSS)

Ocorre quando a aplicação insere dados não validados do usuário diretamente em páginas HTML enviadas ao navegador, permitindo que atacantes injetem código JavaScript malicioso. O navegador executa esse script com os mesmos privilégios da sessão legítima, comprometendo dados da vítima ou sua conta.

Exemplo

Um formulário de busca que exibe o termo digitado na página sem sanitização: se você buscar por '<script>alert(1)</script>', esse script será executado no navegador de quem abrir o resultado. Um atacante pode roubar cookies de sessão ou redirecionar para um site falso.

Como mitigar

Valide e escape todos os dados do usuário antes de renderizar em HTML (use funções nativas como textContent em vez de innerHTML). Para entrada de dados, liste o que é permitido (whitelist); para saída, contextualize o escape (HTML, JavaScript, URL). Use Content Security Policy (CSP) como camada adicional para restringir execução de scripts inline.

CVE-2026-89191MEDIUMStored Cross-Site Scripting in SQLView KRISEPSS 0.2%CVE-2025-10138MEDIUMThis-or-That by André Boekhorst <= 1.0.4 - Authenticated (Contributor+) Stored Cross-Site ScriptingEPSS 0.2%CVE-2026-2933MEDIUMYiFang CMS Extended Management D_adManage.php update cross site scriptingEPSS 0.2%CVE-2025-67708MEDIUMReflected cross-site scripting (XSS) vulnerability in ArcGIS Server.EPSS 0.2%CVE-2025-49420HIGHWordPress Ultra Portfolio - WordPress Plugin <= 6.7 - Cross Site Scripting (XSS) VulnerabilityEPSS 0.2%CVE-2025-49390HIGHWordPress Cookie Notice & Consent plugin <= 1.6.4 - Cross Site Scripting (XSS) vulnerabilityEPSS 0.2%CVE-2025-49424HIGHWordPress Support Ticket Plugin <= 1.9 - Cross Site Scripting (XSS) VulnerabilityEPSS 0.2%CVE-2025-50040MEDIUMWordPress CF7 Spreadsheets Plugin <= 2.3.2 - Cross Site Scripting (XSS) VulnerabilityEPSS 0.2%CVE-2025-52764HIGHWordPress flexoslider plugin <= 1.0004 - Cross Site Scripting (XSS) vulnerabilityEPSS 0.2%CVE-2026-3402MEDIUMPHPGurukul Student Record Management System edit-course.php cross site scriptingEPSS 0.2%CVE-2026-113482MEDIUMMedia Library Assistant < 3.44 - Contributor+ Stored XSS via mla_item_parameter Shortcode AttributeEPSS 0.2%CVE-2026-48538MEDIUMGFI Archiver < 15.13 Stored XSS via ImportSettingsWizard.ashxEPSS 0.2%CVE-2025-53319HIGHWordPress Raptive Ads Plugin <= 3.8.0 - Cross Site Scripting (XSS) VulnerabilityEPSS 0.2%CVE-2026-88742MEDIUMBacularis 1.0.0 - 6.5.0 is vulnerable to Stored cross-site scripting (XSS) in the client address field.EPSS 0.2%CVE-2026-45694MEDIUMLibreNMS: Reflected XSS in the Proxmox app view via unsanitized instance/vmid parametersEPSS 0.2%CVE-2026-48531MEDIUMGFI Archiver < 15.13 Stored XSS via RetentionPolicyWizard.aspxEPSS 0.2%CVE-2025-54737HIGHWordPress Jobmonster theme <= 4.7.8 - Cross Site Scripting (XSS) vulnerabilityEPSS 0.2%CVE-2025-58857HIGHWordPress Table of content Plugin <= 1.5.3.1 - Cross Site Request Forgery (CSRF) VulnerabilityEPSS 0.2%CVE-2026-34096MEDIUMGuardian Language-System XSS via name Parameter in designer.phpEPSS 0.2%CVE-2026-110239LOWRapyd Admin before 9.20.0 Stored XSS via rich-text ComponentEPSS 0.2%