Falhas do tipo CWE-79

30.266 resultados

Injeção de Script entre Sites (XSS)

Ocorre quando a aplicação insere dados não validados do usuário diretamente em páginas HTML enviadas ao navegador, permitindo que atacantes injetem código JavaScript malicioso. O navegador executa esse script com os mesmos privilégios da sessão legítima, comprometendo dados da vítima ou sua conta.

Exemplo

Um formulário de busca que exibe o termo digitado na página sem sanitização: se você buscar por '<script>alert(1)</script>', esse script será executado no navegador de quem abrir o resultado. Um atacante pode roubar cookies de sessão ou redirecionar para um site falso.

Como mitigar

Valide e escape todos os dados do usuário antes de renderizar em HTML (use funções nativas como textContent em vez de innerHTML). Para entrada de dados, liste o que é permitido (whitelist); para saída, contextualize o escape (HTML, JavaScript, URL). Use Content Security Policy (CSP) como camada adicional para restringir execução de scripts inline.

CVE-2025-10913HIGHXSS in saastech.io's TemizlikYoldaEPSS 0.3%CVE-2026-2546MEDIUMLigeroSmart index.pl cross site scriptingEPSS 0.3%CVE-2025-30858HIGHWordPress Snow Storm plugin <= 1.4.6 - Reflected Cross Site Scripting (XSS) vulnerabilityEPSS 0.3%CVE-2025-23425HIGHWordPress Marekkis Watermark plugin <= 0.9.4 - Reflected Cross Site Scripting (XSS) vulnerabilityEPSS 0.3%CVE-2025-31536HIGHWordPress CF7 Spreadsheets plugin <= 2.3.2 - Reflected Cross Site Scripting (XSS) vulnerabilityEPSS 0.3%CVE-2024-13434MEDIUMWP Inventory Manager <= 2.3.2 - Reflected Cross-Site ScriptingEPSS 0.3%CVE-2025-31467HIGHWordPress Flickr Photostream plugin <= 3.1.8 - Reflected Cross Site Scripting (XSS) vulnerabilityEPSS 0.3%CVE-2025-0877MEDIUMXSS in AtaksAPP's Reservation Management SystemEPSS 0.3%CVE-2024-13073MEDIUMXSS in Akinsoft's TaskPanoEPSS 0.3%CVE-2025-30616HIGHWordPress Latest Custom Post Type Updates plugin <= 1.3.0 - Reflected Cross Site Scripting (XSS) vulnerabilityEPSS 0.3%CVE-2025-25132HIGHWordPress Visitor Details plugin <= 1.0.1 - Cross Site Scripting (XSS) vulnerabilityEPSS 0.3%CVE-2025-30611HIGHWordPress Wptobe-signinup plugin <= 1.1.2 - Reflected Cross Site Scripting (XSS) vulnerabilityEPSS 0.3%CVE-2024-40599MEDIUMAn issue was discovered in the GuMaxDD skin for MediaWiki through 1.42.1. There is stored XSS via MediaWiki:Sidebar top-level menu entries.EPSS 0.3%CVE-2024-9608MEDIUMMyParcel <= 4.24.1 - Reflected Cross-Site ScriptingEPSS 0.3%CVE-2024-12072MEDIUMAnalytics Cat – Google Analytics Made Easy <= 1.1.2 - Reflected Cross-Site ScriptingEPSS 0.3%CVE-2024-13404MEDIUMLink Library <= 7.7.2 - Reflected Cross-Site ScriptingEPSS 0.3%CVE-2026-4899MEDIUMcode-projects Online Food Ordering System food.php cross site scriptingEPSS 0.3%CVE-2024-53737MEDIUMWordPress WP Mailster plugin <= 1.8.16.0 - Cross Site Scripting (XSS) vulnerabilityEPSS 0.3%CVE-2024-13464MEDIUMLibrary Bookshelves <= 5.10 - Authenticated (Contributor+) Stored Cross-Site ScriptingEPSS 0.3%CVE-2025-10631MEDIUMitsourcecode Online Petshop Management System Available Products addcnp.php cross site scriptingEPSS 0.3%