CVE-2022-41915: medium-severity vulnerability in netty
Published · Updated
E-mail alert when it lands in KEV, gets a public PoC or its score goes up.
No sign of exploitation. No public exploitation artifact known so far.
Netty's HTTP header handling fails to validate values when using an iterator, allowing attackers to inject malicious headers that split HTTP responses and potentially hijack user sessions or inject malicious content.
CVE-2022-41915 affects Netty 4.1.83.Final through 4.1.85.Final where DefaultHttpHeaders.set() with an Iterator parameter lacks proper header value sanitization (CWE-113). An attacker can supply crafted header values containing CRLF sequences via iterator-based API calls to perform HTTP Response Splitting (CWE-436), bypassing validation that occurs in other code paths. Patched in 4.1.86.Final.
In the same product, most dangerous first.