Weaknesses of type CWE-79

29,881 results

Injeção de conteúdo não sanitizado (XSS)

Ocorre quando dados não confiáveis (entrada de usuário, parâmetros, APIs externas) são inseridos diretamente no HTML, JavaScript ou contexto de renderização sem validação ou escape. Um atacante injeta código malicioso que executa no navegador da vítima, roubando cookies, sessões ou realizando ações em seu nome.

Example

Uma página de busca que exibe o termo procurado sem escape: se o usuário buscar por '<script>alert("hackeado")</script>', esse código é executado no navegador de quem visualizar o resultado. Um atacante pode injetar um script que rouba o token de autenticação.

How to mitigate

Escape ou encode toda entrada antes de renderizá-la (use funções nativas como textContent em JS, template engines com auto-escape como Jinja2 ou escapeHtml). Implemente Content Security Policy (CSP) para restringir execução de scripts inline. Valide e sanitize entrada no servidor, nunca confie apenas em validação client-side.

CVE-2023-23832MEDIUMWordPress Ultimate WP Query Search Filter Plugin <= 1.0.10 is vulnerable to Cross Site Scripting (XSS)EPSS 0.4%CVE-2025-22529MEDIUMWordPress WE Blocks <= 1.3.5 - Cross Site Scripting (XSS) vulnerabilityEPSS 0.4%CVE-2026-54263HIGHWagtail: Reflected XSS in dynamic image URL generator viewEPSS 0.4%CVE-2024-49758MEDIUMLibreNMS has a stored XSS in ExamplePlugin with Device's NotesEPSS 0.4%CVE-2023-23670MEDIUMWordPress Fancy Comments WordPress Plugin <= 1.2.10 is vulnerable to Cross Site Scripting (XSS)EPSS 0.4%CVE-2023-23877MEDIUMWordPress Pinterest RSS Widget Plugin <= 2.3.1 is vulnerable to Cross Site Scripting (XSS)EPSS 0.4%CVE-2022-45821MEDIUMWordPress NOO Timetable Plugin <= 2.1.3 is vulnerable to Cross Site Scripting (XSS)EPSS 0.4%CVE-2023-25798MEDIUMWordPress Olevmedia Shortcodes Plugin <= 1.1.9 is vulnerable to Cross Site Scripting (XSS)EPSS 0.4%CVE-2023-29435MEDIUMWordPress Cryptocurrency All-in-One Plugin <= 3.0.19 is vulnerable to Cross Site Scripting (XSS)EPSS 0.4%CVE-2026-38671MEDIUMCross Site Scripting vulnerability in Ellucian Banner Student Registration Self-Service (StudentRegistrationSsb) 9.23 and prior (no fixed veEPSS 0.4%CVE-2024-41676MEDIUMMagento LTS vulnerable to stored Cross-site Scripting (XSS) in admin system configsEPSS 0.4%CVE-2025-9422MEDIUMoitcode samarium Team Image team cross site scriptingEPSS 0.4%CVE-2023-23867MEDIUMWordPress Button Builder – Buttons X Plugin <= 0.8.6 is vulnerable to Cross Site Scripting (XSS)EPSS 0.4%CVE-2023-23685MEDIUMWordPress Portfolio – WordPress Portfolio Plugin Plugin <= 2.8.10 is vulnerable to Cross Site Scripting (XSS)EPSS 0.4%CVE-2023-39988MEDIUMWordPress WxSync Plugin <= 2.7.23 is vulnerable to Cross Site Scripting (XSS)EPSS 0.4%CVE-2024-4569MEDIUMElementor Addon Elements <= 1.13.5 - Authenticated (Contributor+) Stored Cross-Site ScriptingEPSS 0.4%CVE-2023-23676MEDIUMWordPress File Gallery Plugin <= 1.8.5.3 is vulnerable to Cross Site Scripting (XSS)EPSS 0.4%CVE-2023-32576MEDIUMWordPress Locatoraid Store Locator Plugin <= 3.9.18 is vulnerable to Cross Site Scripting (XSS)EPSS 0.4%CVE-2023-45049MEDIUMWordPress YouTube Playlist Player Plugin <= 4.6.7 is vulnerable to Cross Site Scripting (XSS)EPSS 0.4%CVE-2023-30780MEDIUMWordPress User IP and Location Plugin <= 2.2 is vulnerable to Cross Site Scripting (XSS)EPSS 0.4%