Weaknesses of type CWE-79

29,990 results

Injeção de conteúdo não sanitizado (XSS)

Ocorre quando dados não confiáveis (entrada de usuário, parâmetros, APIs externas) são inseridos diretamente no HTML, JavaScript ou contexto de renderização sem validação ou escape. Um atacante injeta código malicioso que executa no navegador da vítima, roubando cookies, sessões ou realizando ações em seu nome.

Example

Uma página de busca que exibe o termo procurado sem escape: se o usuário buscar por '<script>alert("hackeado")</script>', esse código é executado no navegador de quem visualizar o resultado. Um atacante pode injetar um script que rouba o token de autenticação.

How to mitigate

Escape ou encode toda entrada antes de renderizá-la (use funções nativas como textContent em JS, template engines com auto-escape como Jinja2 ou escapeHtml). Implemente Content Security Policy (CSP) para restringir execução de scripts inline. Valide e sanitize entrada no servidor, nunca confie apenas em validação client-side.

CVE-2024-33537MEDIUMWordPress WP Portfolio theme <= 2.4 - Cross Site Scripting (XSS) vulnerabilityEPSS 0.4%CVE-2024-32133HIGHWordPress EZ Form Calculator plugin <= 2.14.0.3 - Reflected Cross Site Scripting (XSS) vulnerabilityEPSS 0.4%CVE-2024-43792MEDIUMHalo's editor has a stored Cross-Site Scripting vulnerabilityEPSS 0.4%CVE-2026-33955HIGHNotesnook vulnerable to RCE via stored XSS in Note History diff viewerEPSS 0.4%CVE-2024-2835HIGHOpenText ArcSight Enterprise Security Manager and ArcSight Platform Stored XSSEPSS 0.4%CVE-2024-30445MEDIUMWordPress Web Icons plugin <= 1.0.0.10 - Cross Site Scripting (XSS) vulnerabilityEPSS 0.4%CVE-2024-3482HIGHOpenText ArcSight Enterprise Security Manager and ArcSight Platform Stored XSSEPSS 0.4%CVE-2024-29761MEDIUMWordPress WP Post Disclaimer plugin <= 1.0.3 - Cross Site Scripting (XSS) vulnerabilityEPSS 0.4%CVE-2024-29795MEDIUMWordPress Media Cloud for Amazon S3, Cloudflare R2, Google Cloud Storage, DigitalOcean Spaces and more plugin <= 4.5.24 - Cross Site Scripting (XSS) vulnerabilityEPSS 0.4%CVE-2024-49505MEDIUMXSS vulnerability found in OpenSuse MirrorCacheEPSS 0.4%CVE-2024-29769MEDIUMWordPress Portfolio Gallery plugin <= 1.5.6 - Cross Site Scripting (XSS) vulnerabilityEPSS 0.4%CVE-2025-54495MEDIUMA reflected cross-site scripting (xss) vulnerability exists in the emailfailedjob functionality of MedDream PACS Premium 7.3.6.870. A speciaEPSS 0.4%CVE-2023-46313HIGHWordPress Zotpress Plugin <= 7.3.4 is vulnerable to Cross Site Scripting (XSS)EPSS 0.4%CVE-2024-10101MEDIUMStored XSS in binary-husky/gpt_academicEPSS 0.4%CVE-2023-4802MEDIUMITM Server Cross-site Scripting in UpdateInstalledSoftware EndpointEPSS 0.4%CVE-2025-22524MEDIUMWordPress فرم ساز فرم افزار Plugin <= 2.0 - Cross Site Scripting (XSS) vulnerabilityEPSS 0.4%CVE-2024-29798MEDIUMWordPress Gratisfaction plugin <= 4.3.4 - Cross Site Scripting (XSS) vulnerabilityEPSS 0.4%CVE-2024-27196HIGHWordPress postMash – custom post order plugin <= 1.2.0 - Reflected Cross Site Scripting (XSS) vulnerabilityEPSS 0.4%CVE-2024-29762MEDIUMWordPress Off-Canvas Sidebars & Menus (Slidebars) plugin <= 0.5.8.1 - Cross Site Scripting (XSS) vulnerabilityEPSS 0.4%CVE-2025-54157MEDIUMA reflected cross-site scripting (xss) vulnerability exists in the encapsulatedDoc functionality of MedDream PACS Premium 7.3.6.870. A speciEPSS 0.4%