CVE-2022-21647: fallo de gravedad alta en CodeIgniter4
Deserialization of Untrusted Data in Codeigniter4
Publicada el · Actualizada el
Aviso por correo cuando entre en el KEV, tenga PoC pública o suba de nota.
33Vexday Risk Score
Sin señal de explotación. Ningún artefacto público de explotación conocido hasta ahora.
ssvc Trackcvss 7.7epss 38%
CodeIgniter is an open source PHP full-stack web framework. Deserialization of Untrusted Data was found in the `old()` function in CodeIgniter4. Remote attackers may inject auto-loadable arbitrary objects with this vulnerability, and possibly execute existing PHP code on the server. We are aware of a working exploit, which can lead to SQL injection. Users are advised to upgrade to v4.1.6 or later. Users unable to upgrade as advised to not use the `old()` function and form_helper nor `RedirectResponse::withInput()` and `redirect()->withInput()`.
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:H/A:H
Productos afectados
codeigniter4 · CodeIgniter4CVEs relacionadas — CodeIgniter4
En el mismo producto, de las más peligrosas a las menos.
CVE-2025-54418CRITICALCodeIgniter4's ImageMagick Handler has Command Injection VulnerabilityEPSS 1.5%CVE-2022-24711CRITICALRemote CLI Command Execution Vulnerability in CodeIgniter4EPSS 1.2%CVE-2023-32692CRITICALRemote Code Execution Vulnerability in Validation PlaceholdersEPSS 1.1%CVE-2022-39284LOWSecure or HttpOnly flag set in Config\Cookie is not reflected in Cookies issued in Codeigniter4EPSS 1.1%CVE-2022-21715MEDIUMCross-site Scripting Vulnerability in CodeIgniter4EPSS 1.0%CVE-2022-46170HIGHCodeIgniter is vulnerable to improper authentication via Session HandlersEPSS 0.9%