CVE-2025-2075: fallo de gravedad alta en uncannyowl Uncanny Automator – Easy…
Uncanny Automator <= 6.3.0.2 - Missing Authorization to Authenticated (Subscriber+) Privilege Escalation
Publicada el · Actualizada el
Seguir esta CVE+ Monitorear Uncanny Automator – Easy Automation, Integration, Webhooks & Workflow Builder Plugin
Aviso por correo cuando entre en el KEV, tenga PoC pública o suba de nota.
58Vexday Risk Score
Corrige ahora. Ella explotación observada por VulnCheck y tiene exploit funcional público.
ssvc Actcvss 8.8epss 2.8%
de la publicación al arma
Publicada en NVD4 abr
VulnCheck4 abr
The Uncanny Automator – Easy Automation, Integration, Webhooks & Workflow Builder Plugin for WordPress is vulnerable to Privilege Escalation in all versions up to, and including, 6.3.0.2. This is due to add_role() and user_role() functions missing proper capability checks performed through the validate_rest_call() function. This makes it possible for unauthenticated attackers to set the role of arbitrary users to administrator granting full access to the site, though privilege escalation requires an active account on the site so this is considered an authenticated privilege escalation.
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Productos afectados
uncannyowl · Uncanny Automator – Easy Automation, Integration, Webhooks & Workflow Builder PluginCVEs relacionadas — uncannyowl Uncanny Automator – Easy…
En el mismo producto, de las más peligrosas a las menos.
CVE-2026-15008HIGHUncanny Automator <= 7.3.1.4 - Unauthenticated PHP Object Injection to Arbitrary File Deletion via Forminator Submitted-Field TokenEPSS 1.0%CVE-2025-3623CRITICALUncanny Automator <= 6.4.0.1 - Unauthenticated PHP Object Injection in automator_api_decode_message FunctionEPSS 0.9%CVE-2026-2269HIGHUncanny Automator – Easy Automation, Integration, Webhooks & Workflow Builder Plugin <= 7.0.0.3 - Authenticated (Administrator+) Server-Side Request Forgery to Arbitrary File UploadEPSS 0.7%CVE-2026-15025HIGHUncanny Automator <= 7.3.2 - Missing Authorization to Authenticated (Subscriber+) Sensitive Integration Metadata Disclosure via Multiple AJAX EndpointsEPSS 0.7%CVE-2024-13838MEDIUMUncanny Automator – Easy Automation, Integration, Webhooks & Workflow Builder Plugin <= 6.2 - Authenticated (Admin+) Server-Side Request Forgery via WebhookEPSS 0.3%CVE-2025-4520MEDIUMUncanny Automator <= 6.4.0.2 - Missing Authorization to Authenticated (Subscriber+) Plugin Settings UpdateEPSS 0.3%
Referencias
https://plugins.trac.wordpress.org/changeset/3257300/uncanny-automator/trunk/src/core/classes/class-background-actions.phphttps://plugins.trac.wordpress.org/changeset/3265280/uncanny-automator/trunk/src/core/classes/class-background-actions.phphttps://www.wordfence.com/threat-intel/vulnerabilities/id/86b4b0d6-bda2-47f3-a0b5-9733cb7a11f6?source=cve