CVE-2025-53107highCWE-77

CVE-2025-53107: fallo de gravedad alta en cyanheads git-mcp-server

@cyanheads/git-mcp-server vulnerable to command injection in several tools

Publicada el

Aviso por correo cuando entre en el KEV, tenga PoC pública o suba de nota.

26Vexday Risk Score

Sin señal de explotación. Ningún artefacto público de explotación conocido hasta ahora.

ssvc Trackcvss 7.5epss 25%
@cyanheads/git-mcp-server is an MCP server designed to interact with Git repositories. Prior to version 2.1.5, there is a command injection vulnerability caused by the unsanitized use of input parameters within a call to child_process.exec, enabling an attacker to inject arbitrary system commands. Successful exploitation can lead to remote code execution under the server process's privileges. The server constructs and executes shell commands using unvalidated user input directly within command-line strings. This introduces the possibility of shell metacharacter injection (|, >, &&, etc.). An MCP Client can be instructed to execute additional actions for example via indirect prompt injection when asked to read git logs. This issue has been patched in version 2.1.5.
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
Productos afectados
cyanheads · git-mcp-server
CVEs relacionadas — cyanheads git-mcp-server

En el mismo producto, de las más peligrosas a las menos.