CVE-2026-115869: fallo de gravedad media en themifyme Themify Builder
Themify Builder <= 7.8.4 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'variations' Repeater Field
Publicada el
Aviso por correo cuando entre en el KEV, tenga PoC pública o suba de nota.
13Vexday Risk Score
Sin señal de explotación. Ningún artefacto público de explotación conocido hasta ahora.
ssvc Trackcvss 6.4epss 0.3%
The Themify Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'variations' repeater field of Custom Font (tb_cf) posts in versions up to, and including, 7.8.4. This is due to insufficient input sanitization and output escaping on the variations post meta: Themify_Metabox::_save_meta() only passes the value through wp_kses_data() when the field type is 'textbox' or 'textarea', so the 'repeater' field writes attacker-controlled sub-fields (style, woff/woff2/ttf/svg/eot URLs) to update_post_meta() verbatim, and Themify_Custom_Fonts::render_columns() later echoes those values unescaped inside a <style> block on the Custom Fonts admin listing. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page (specifically, the Custom Fonts admin listing).
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Productos afectados
themifyme · Themify BuilderCVEs relacionadas — themifyme Themify Builder
En el mismo producto, de las más peligrosas a las menos.
CVE-2026-75027MEDIUMThemify Builder <= 7.8.0 - Missing Authorization to Unauthenticated Arbitrary Builder Data Modification via 'tb_update_old_data' AJAX ActionEPSS 0.6%CVE-2026-15407MEDIUMThemify Builder <= 7.7.7 - Missing Authorization to Authenticated (Subscriber+) Arbitrary Post Stylesheet Write/Delete via tb_generate_on_fly AJAX ActionEPSS 0.5%CVE-2024-56216MEDIUMWordPress Themify Builder plugin <= 7.6.3 - Local File Inclusion vulnerabilityEPSS 0.5%CVE-2024-9385MEDIUMThemify Builder <= 7.6.2 - Reflected Cross-Site ScriptingEPSS 0.4%CVE-2026-15097MEDIUMThemify Builder <= 7.7.6 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'height_slider' Slider Module FieldEPSS 0.3%CVE-2026-96831HIGHWordPress Themify Builder plugin <= 7.8.1 - PHP Object Injection vulnerabilityEPSS 0.3%
Referencias
https://plugins.trac.wordpress.org/browser/themify-builder/tags/7.8.4/themify/class-themify-custom-fonts.php#L287https://plugins.trac.wordpress.org/browser/themify-builder/tags/7.8.4/themify/themify-metabox/includes/themify-metabox-core.php#L208https://plugins.trac.wordpress.org/browser/themify-builder/tags/7.8.4/themify/themify-metabox/includes/themify-metabox-core.php#L230https://plugins.trac.wordpress.org/changeset?reponame=&old=3774070%40themify-builder&new=3774070%40themify-builderhttps://www.wordfence.com/threat-intel/vulnerabilities/id/cf80f304-f79d-4863-b57a-d273daa5fe7f?source=cve