CVE-2026-75913: fallo de gravedad alta en Hmbown CodeWhale
CodeWhale before 0.8.64 Argument Injection via git_show
Publicada el · Actualizada el
Aviso por correo cuando entre en el KEV, tenga PoC pública o suba de nota.
21Vexday Risk Score
Sin señal de explotación. Ningún artefacto público de explotación conocido hasta ahora.
ssvc Trackcvss 8.5epss 0.5%
CodeWhale versions >= 0.3.27 and < 0.8.64 (published as deepseek-tui >= 0.3.27 and < 0.8.41 on npm and 0.3.27 through 0.8.41 on crates.io, and as codewhale / codewhale-tui >= 0.8.41 and < 0.8.64) contain an argument injection vulnerability in the git_show tool. The model-supplied rev parameter is passed unvalidated into the git show argv without an --end-of-options sentinel, so a value beginning with --output= is interpreted as a git flag. Because the tool is registered as auto-approved and advertised as read-only, an attacker (via a malicious repository combined with prompt injection) can cause an unprompted arbitrary file write at the privilege of the invoking user, targeting sensitive files such as ~/.ssh/authorized_keys, ~/.bashrc, or ~/.gitconfig. Fixed in codewhale / codewhale-tui 0.8.64 by adding rev validation; the deprecated deepseek-tui crate has no fixed release.
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:H/VA:H/SC:N/SI:H/SA:H
Productos afectados
Hmbown · CodeWhaleCVEs relacionadas — Hmbown CodeWhale
En el mismo producto, de las más peligrosas a las menos.
CVE-2026-75915HIGHCodeWhale before 0.8.64 Environment Variable Leak via js_executionEPSS 0.7%CVE-2026-45311CRITICALCodeWhale: run_tests Tool Enables RCE via Malicious Repository Without ApprovalEPSS 0.6%CVE-2026-75914HIGHCodeWhale before 0.8.64 Path Traversal via image_analyze symlinkEPSS 0.5%CVE-2026-75859HIGHCodeWhale before 0.8.64 Arbitrary File Read via instructionsEPSS 0.5%CVE-2026-75856CRITICALCodeWhale before 0.8.64 SSRF Bypass via DNS Pinning TOCTOUEPSS 0.5%CVE-2026-75912HIGHCodeWhale before 0.8.64 Argument Injection via git_blameEPSS 0.4%