CVE-2022-24822: falha de alta gravidade em podium-lib proxy
Denial of Service in @podium/layout and @podium/proxy
Publicada em · Atualizada em
Aviso por e-mail quando ela entrar no KEV, ganhar PoC pública ou subir de nota.
21Vexday Risk Score
Sem sinal de exploração. Nenhum artefato público de exploração conhecido até agora.
ssvc Trackcvss 7.5epss 1.7%
Podium is a library for building micro frontends. @podium/layout is a module for building a Podium layout server, and @podium/proxy is a module for proxying HTTP requests from a layout server to a podlet server. In @podium/layout prior to version 4.6.110 and @podium/proxy prior to version 4.2.74, an attacker using the `Trailer` header as part of the request against proxy endpoints has the ability to take down the server. All Podium layouts that include podlets with proxy endpoints are affected. `@podium/layout`, which is the main way developers/users are vulnerable to this exploit, has been patched in version `4.6.110`. All earlier versions are vulnerable.`@podium/proxy`, which is the source of the vulnerability and is used by `@podium/layout` has been patched in version `4.2.74`. All earlier versions are vulnerable. It is not easily possible to work around this issue without upgrading.
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Produtos afetados
podium-lib · proxyReferências
https://github.com/podium-lib/layout/commit/fe43e655432b0a5f07b6475f67babcc2588fb039https://github.com/podium-lib/layout/releases/tag/v4.6.110https://github.com/podium-lib/proxy/commit/9698a40df081217ce142d4de71f929baaa339cdfhttps://github.com/podium-lib/proxy/releases/tag/v4.2.74https://github.com/podium-lib/proxy/security/advisories/GHSA-3hjg-vc7r-rcrw