CVE-2022-31157highCWE-327

CVE-2022-31157: falha de alta gravidade em packbackbooks lti-1-3-php-library

Use of a Broken or Risky Cryptographic Algorithm in packbackbooks/lti-1-3-php-library

Publicada em · Atualizada em

Aviso por e-mail quando ela entrar no KEV, ganhar PoC pública ou subir de nota.

21Vexday Risk Score

Sem sinal de exploração. Nenhum artefato público de exploração conhecido até agora.

ssvc Trackcvss 7.5epss 0.5%
LTI 1.3 Tool Library is a library used for building IMS-certified LTI 1.3 tool providers in PHP. Prior to version 5.0, the function used to generate random nonces was not sufficiently cryptographically complex. Users should upgrade to version 5.0 to receive a patch. There are currently no known workarounds.
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
CVEs relacionadas — packbackbooks lti-1-3-php-library

No mesmo produto, das mais perigosas para as menos.