CVE-2023-47248: falha em Apache Software Foundation PyArrow
PyArrow, PyArrow: Arbitrary code execution when loading a malicious data file
Publicada em · Atualizada em
Aviso por e-mail quando ela entrar no KEV, ganhar PoC pública ou subir de nota.
45Vexday Risk Score
Corrija agora. Ela exploração observada pelo VulnCheck e tem exploit funcional público.
ssvc Actepss 15%
da publicação à arma
Publicada no NVD9 de nov.
VulnCheck+493d
Deserialization of untrusted data in IPC and Parquet readers in PyArrow versions 0.14.0 to 14.0.0 allows arbitrary code execution. An application is vulnerable if it reads Arrow IPC, Feather or Parquet data from untrusted sources (for example user-supplied input files).
This vulnerability only affects PyArrow, not other Apache Arrow implementations or bindings.
It is recommended that users of PyArrow upgrade to 14.0.1. Similarly, it is recommended that downstream libraries upgrade their dependency requirements to PyArrow 14.0.1 or later. PyPI packages are already available, and we hope that conda-forge packages will be available soon.
If it is not possible to upgrade, we provide a separate package `pyarrow-hotfix` that disables the vulnerability on older PyArrow versions. See https://pypi.org/project/pyarrow-hotfix/ for instructions.
Produtos afetados
Apache Software Foundation · PyArrowCVEs relacionadas — Apache Software Foundation PyArrow
No mesmo produto, das mais perigosas para as menos.
Referências
https://github.com/apache/arrow/commit/f14170976372436ec1d03a724d8d3f3925484ecfhttps://lists.apache.org/thread/yhy7tdfjf9hrl9vfrtzo8p2cyjq87v7nhttps://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/FR34AIPXVTMB3XPRU5ULV5HHWPMRE33X/https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/MAGWEAJDWO2ACYATUQCPXLSYY5C3L3XU/https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/MWFYXLVBTBHNKYRXI572RFX7IJDDQGBL/https://pypi.org/project/pyarrow-hotfix/