CVE-2024-5221: falha de média gravidade em qodeinteractive Qi Blocks
Qi Blocks <= 1.2.9 - Authenticated (Author+) Stored Cross-Site Scripting
Publicada em · Atualizada em
Aviso por e-mail quando ela entrar no KEV, ganhar PoC pública ou subir de nota.
13Vexday Risk Score
Sem sinal de exploração. Nenhum artefato público de exploração conhecido até agora.
ssvc Trackcvss 6.4epss 0.3%
The Qi Blocks plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's file uploader in all versions up to, and including, 1.2.9 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Produtos afetados
qodeinteractive · Qi BlocksCVEs relacionadas — qodeinteractive Qi Blocks
No mesmo produto, das mais perigosas para as menos.
CVE-2026-10096MEDIUMQi Blocks <= 1.4.9 - Insecure Direct Object Reference to Authenticated (Author+) Arbitrary Style Modification via 'page_id' ParameterEPSS 0.3%CVE-2025-12182MEDIUMQi Blocks <= 1.4.3 - Missing Authorization to Arbitrary Attachment ResizeEPSS 0.2%CVE-2025-12180MEDIUMQi Blocks <= 1.4.3 - Missing Authorization to Authenticated (Contributor+) Plugin Settings UpdateEPSS 0.2%