CVE-2025-48924: falha de média gravidade em Apache Commons Lang
Apache Commons Lang, Apache Commons Lang: ClassUtils.getClass(...) can throw a StackOverflowError on very long inputs
Publicada em · Atualizada em
Aviso por e-mail quando ela entrar no KEV, ganhar PoC pública ou subir de nota.
13Vexday Risk Score
Sem sinal de exploração. Nenhum artefato público de exploração conhecido até agora.
ssvc Trackcvss 5.3epss 2.6%
Uncontrolled Recursion vulnerability in Apache Commons Lang.
This issue affects Apache Commons Lang: Starting with commons-lang:commons-lang 2.0 to 2.6, and, from org.apache.commons:commons-lang3 3.0 before 3.18.0.
The methods ClassUtils.getClass(...) can throw StackOverflowError on very long inputs. Because an Error is usually not handled by applications and libraries, a
StackOverflowError could cause an application to stop.
Users are recommended to upgrade to version 3.18.0, which fixes the issue.
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Produtos afetados
Apache Software Foundation · Apache Commons LangReferências
https://lists.apache.org/thread/bgv0lpswokgol11tloxnjfzdl7yrc1g1https://lists.debian.org/debian-lts-announce/2025/08/msg00000.htmlhttps://lists.debian.org/debian-lts-announce/2025/08/msg00026.htmlhttps://lists.debian.org/debian-lts-announce/2025/09/msg00032.htmlhttps://lists.debian.org/debian-lts-announce/2025/09/msg00036.htmlhttp://www.openwall.com/lists/oss-security/2025/07/11/1