CVE-2020-5210: medium-severity vulnerability in NetHack
NetHack command line -w option parsing is subject to a buffer overflow
Published · Updated
E-mail alert when it lands in KEV, gets a public PoC or its score goes up.
13Vexday Risk Score
No sign of exploitation. No public exploitation artifact known so far.
ssvc Trackcvss 5epss 0.8%
In NetHack before 3.6.5, an invalid argument to the -w command line option can cause a buffer overflow resulting in a crash or remote code execution/privilege escalation. This vulnerability affects systems that have NetHack installed suid/sgid and shared systems that allow users to influence command line options. Users should upgrade to NetHack 3.6.5.
CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:L
Affected products
NetHack · NetHackRelated CVEs — NetHack
In the same product, most dangerous first.
CVE-2020-5254LOWNetHack hilite_status parsing privilege escalationEPSS 1.1%CVE-2020-5211MEDIUMNetHack AUTOCOMPLETE configuration file option is subject to a buffer overflowEPSS 1.1%CVE-2020-5214MEDIUMNetHack error recovery after syntax error in configuration file is subject to a buffer overflowEPSS 1.1%CVE-2020-5212MEDIUMNetHack MENUCOLOR configuration file option is subject to a buffer overflowEPSS 1.1%CVE-2020-5213MEDIUMNetHack SYMBOL configuration file option is subject to a buffer overflowEPSS 1.1%CVE-2020-5209MEDIUMNetHack command line parsing of options starting with -de and -i is subject to a buffer overflowEPSS 0.8%