CVE-2022-39284: low-severity vulnerability in CodeIgniter4
Secure or HttpOnly flag set in Config\Cookie is not reflected in Cookies issued in Codeigniter4
Published · Updated
8Vexday Risk Score
No sign of exploitation. No public exploitation artifact known so far.
ssvc Trackcvss 2.6epss 1.1%
exploitation probability
1.1%top 34% of all CVEs
observed exploitation
nono source reports it
CodeIgniter is a PHP full-stack web framework. In versions prior to 4.2.7 setting `$secure` or `$httponly` value to `true` in `Config\Cookie` is not reflected in `set_cookie()` or `Response::setCookie()`. As a result cookie values are erroneously exposed to scripts. It should be noted that this vulnerability does not affect session cookies. Users are advised to upgrade to v4.2.7 or later. Users unable to upgrade are advised to manually construct their cookies either by setting the options in code or by constructing Cookie objects. Examples of each workaround are available in the linked GHSA.
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:N/A:N
Affected products
codeigniter4 · CodeIgniter4Related CVEs — CodeIgniter4
In the same product, most dangerous first.
CVE-2022-21647HIGHDeserialization of Untrusted Data in Codeigniter4EPSS 37.7%CVE-2025-54418CRITICALCodeIgniter4's ImageMagick Handler has Command Injection VulnerabilityEPSS 1.5%CVE-2022-24711CRITICALRemote CLI Command Execution Vulnerability in CodeIgniter4EPSS 1.2%CVE-2023-32692CRITICALRemote Code Execution Vulnerability in Validation PlaceholdersEPSS 1.1%CVE-2022-21715MEDIUMCross-site Scripting Vulnerability in CodeIgniter4EPSS 1.0%CVE-2022-46170HIGHCodeIgniter is vulnerable to improper authentication via Session HandlersEPSS 0.9%
References
https://codeigniter4.github.io/userguide/helpers/cookie_helper.html#set_cookiehttps://codeigniter4.github.io/userguide/outgoing/response.html#CodeIgniter%5CHTTP%5CResponse::setCookiehttps://developer.mozilla.org/en-US/docs/Web/HTTP/Cookies#restrict_access_to_cookieshttps://github.com/codeigniter4/CodeIgniter4/issues/6540https://github.com/codeigniter4/CodeIgniter4/pull/6544https://github.com/codeigniter4/CodeIgniter4/security/advisories/GHSA-745p-r637-7vvp