CVE-2023-0584: medium-severity vulnerability in vektor-inc VK Blocks
VK Blocks <= 1.57.0.5 - Authenticated(Contributor+) Settings Update
Published · Updated
E-mail alert when it lands in KEV, gets a public PoC or its score goes up.
13Vexday Risk Score
No sign of exploitation. No public exploitation artifact known so far.
ssvc Trackcvss 4.3epss 0.5%
The VK Blocks plugin for WordPress is vulnerable to improper authorization via the REST 'update_options' function in versions up to, and including, 1.57.0.5. This allows authenticated attackers, with contributor-level permissions or above, to change the 'vk_font_awesome_version' option to an arbitrary value.
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Affected products
vektor-inc · VK BlocksRelated CVEs — vektor-inc VK Blocks
In the same product, most dangerous first.
CVE-2023-5706MEDIUMVK Blocks <= 1.63.0.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via BlockEPSS 0.6%CVE-2023-0583MEDIUMVK Blocks <= 1.57.0.5 - Authenticated(Contributor+) Settings UpdateEPSS 0.5%CVE-2024-13635MEDIUMVK Blocks <= 1.94.2.2 - Missing Authorization to Sensitive Information ExposureEPSS 0.3%CVE-2026-78087MEDIUMVK Blocks <= 1.126.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via Group Block 'linkToPost' FeatureEPSS 0.2%