CVE-2023-22946: medium-severity vulnerability in Apache Spark
Apache Spark proxy-user privilege escalation from malicious configuration class
Published · Updated
E-mail alert when it lands in KEV, gets a public PoC or its score goes up.
13Vexday Risk Score
No sign of exploitation. No public exploitation artifact known so far.
ssvc Trackcvss 6.4epss 1.1%
In Apache Spark versions prior to 3.4.0, applications using spark-submit can specify a 'proxy-user' to run as, limiting privileges. The application can execute code with the privileges of the submitting user, however, by providing malicious configuration-related classes on the classpath. This affects architectures relying on proxy-user, for example those using Apache Livy to manage submitted applications.
Update to Apache Spark 3.4.0 or later, and ensure that
spark.submit.proxyUser.allowCustomClasspathInClusterMode is set to its
default of "false", and is not overridden by submitted applications.
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Affected products
Apache Software Foundation · Apache SparkRelated CVEs — Apache Spark
In the same product, most dangerous first.
CVE-2022-33891HIGHApache Spark shell command injection vulnerability via Spark UIEPSS 93.2%KEVCVE-2023-32007HIGHApache Spark: Shell command injection via Spark UIEPSS 76.0%CVE-2018-11770—CVE-2018-11770EPSS 66.1%CVE-2020-9480—CVE-2020-9480EPSS 29.4%CVE-2018-17190—CVE-2018-17190EPSS 8.8%CVE-2018-11804—CVE-2018-11804EPSS 5.7%