CVE-2023-25661: medium-severity vulnerability in tensorflow
Denial of Service in TensorFlow
Published · Updated
E-mail alert when it lands in KEV, gets a public PoC or its score goes up.
13Vexday Risk Score
No sign of exploitation. No public exploitation artifact known so far.
ssvc Trackcvss 6.5epss 0.4%
TensorFlow is an Open Source Machine Learning Framework. In versions prior to 2.11.1 a malicious invalid input crashes a tensorflow model (Check Failed) and can be used to trigger a denial of service attack. A proof of concept can be constructed with the `Convolution3DTranspose` function. This Convolution3DTranspose layer is a very common API in modern neural networks. The ML models containing such vulnerable components could be deployed in ML applications or as cloud services. This failure could be potentially used to trigger a denial of service attack on ML cloud services. An attacker must have privilege to provide input to a `Convolution3DTranspose` call. This issue has been patched and users are advised to upgrade to version 2.11.1. There are no known workarounds for this vulnerability.
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Affected products
tensorflow · tensorflowRelated CVEs — tensorflow
In the same product, most dangerous first.
CVE-2020-15202CRITICALInteger truncation in Shard API usageEPSS 1.3%CVE-2020-15207HIGHSegfault and data corruption in tensorflow-liteEPSS 1.2%CVE-2022-23559HIGHInteger overflow in TFLiteEPSS 1.2%CVE-2022-23581MEDIUM`CHECK`-failures during Grappler's `IsSimplifiableReshape` in TensorflowEPSS 1.2%CVE-2022-23589MEDIUMNull pointer dereference in Grappler's `IsConstant` in TensorflowEPSS 1.1%CVE-2020-15205CRITICALData leak in TensorflowEPSS 1.0%