CVE-2023-49295: medium-severity vulnerability in quic-go
quic-go's path validation mechanism can cause denial of service
Published · Updated
E-mail alert when it lands in KEV, gets a public PoC or its score goes up.
13Vexday Risk Score
No sign of exploitation. No public exploitation artifact known so far.
ssvc Trackcvss 6.4epss 1.2%
quic-go is an implementation of the QUIC protocol (RFC 9000, RFC 9001, RFC 9002) in Go. An attacker can cause its peer to run out of memory sending a large number of PATH_CHALLENGE frames. The receiver is supposed to respond to each PATH_CHALLENGE frame with a PATH_RESPONSE frame. The attacker can prevent the receiver from sending out (the vast majority of) these PATH_RESPONSE frames by collapsing the peers congestion window (by selectively acknowledging received packets) and by manipulating the peer's RTT estimate. This vulnerability has been patched in versions 0.37.7, 0.38.2 and 0.39.4.
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:H
Affected products
quic-go · quic-goRelated CVEs — quic-go
In the same product, most dangerous first.
CVE-2024-22189HIGHQUIC's Connection ID Mechanism vulnerable to Memory Exhaustion AttackEPSS 1.1%CVE-2023-46239HIGHquic-go vulnerable to pointer dereference that can lead to panicEPSS 1.0%CVE-2025-64702MEDIUMquic-go HTTP/3 QPACK Header Expansion DoSEPSS 0.9%CVE-2024-53259MEDIUMquic-go affected by an ICMP Packet Too Large Injection Attack on LinuxEPSS 0.6%CVE-2025-29785HIGHquic-go Has Panic in Path Probe Loss Recovery HandlingEPSS 0.5%CVE-2025-59530HIGHquic-go has Client Crash Due to Premature HANDSHAKE_DONE FrameEPSS 0.5%
References
https://github.com/quic-go/quic-go/commit/17fc98c2d81dbe685c19702dc694a9d606ac56dchttps://github.com/quic-go/quic-go/commit/21609ddfeff93668c7625a85eb09f1541fdad965https://github.com/quic-go/quic-go/commit/3a9c18bcd27a01c551ac9bf8bd2b4bded77c189ahttps://github.com/quic-go/quic-go/commit/554d543b50b917369fb1394cc5396d928166cf49https://github.com/quic-go/quic-go/commit/6cc3d58935426191296171a6c0d1ee965e10534ehttps://github.com/quic-go/quic-go/commit/9aaefe19fc3dc8c8917cc87e6128bb56d9e9e6cchttps://github.com/quic-go/quic-go/commit/a0ffa757499913f7be69aa78f573a6aee3430ae4https://github.com/quic-go/quic-go/commit/d7aa627ebde91cf799ada2a07443faa9b1e5abb8https://github.com/quic-go/quic-go/security/advisories/GHSA-ppxx-5m9h-6vxfhttps://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/G5RSHDTVMYAIGYVVFGKTMFHAZJMA3EVV/https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/ZE7IOKXX5AATU2WR3V76X5Y3A44QAATG/