CVE-2024-13699: medium-severity vulnerability in qodeinteractive Qi Addons For Elementor
Qi Addons For Elementor <= 1.8.7 - Authenticated (Contributor+) Stored Cross-Site Scripting
Published · Updated
E-mail alert when it lands in KEV, gets a public PoC or its score goes up.
13Vexday Risk Score
No sign of exploitation. No public exploitation artifact known so far.
ssvc Trackcvss 6.4epss 0.4%
The Qi Addons For Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘cursor’ parameter in all versions up to, and including, 1.8.7 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerability was partially patched in versions 1.8.5, 1.8.6, and 1.8.7.
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Affected products
qodeinteractive · Qi Addons For ElementorRelated CVEs — qodeinteractive Qi Addons For Elementor
In the same product, most dangerous first.
CVE-2024-4887HIGHQi Addons For Elementor <= 1.7.2 - Authenticated (Contributor+) Local File InclusionEPSS 0.6%CVE-2024-0826MEDIUMQi Addons For Elementor <= 1.6.7 - Authenticated (Contributor+) Stored Cross-Site ScriptingEPSS 0.6%CVE-2024-9530MEDIUMQi Addons For Elementor <= 1.8.0 - Sensitive Information ExposureEPSS 0.4%CVE-2026-92249MEDIUMQi Addons For Elementor <= 1.11 - Reflected DOM-Based Cross-Site Scripting via 's' ParameterEPSS 0.4%CVE-2024-4364MEDIUMQi Addons For Elementor <= 1.7.2 - Authenticated (Contributor+) Stored Cross-Site Scripting via Button WidgetEPSS 0.3%CVE-2024-3309MEDIUMQi Addons For Elementor <= 1.7.0 - Authenticated (Contributor+) Stored Cross-Site Scripting via Countdown widgetEPSS 0.3%
References
https://plugins.trac.wordpress.org/browser/qi-addons-for-elementor/trunk/inc/shortcodes/typeout-text/class-qiaddonsforelementor-typeout-text-shortcode.phphttps://plugins.trac.wordpress.org/changeset/3230342/https://plugins.trac.wordpress.org/changeset/3231980/https://plugins.trac.wordpress.org/changeset/3232550/https://plugins.trac.wordpress.org/changeset/3234136/https://www.wordfence.com/threat-intel/vulnerabilities/id/add39d28-4070-44e2-8dff-0371e0c58453?source=cve