CVE-2024-55633: high-severity vulnerability in Apache Superset
Apache Superset: SQLLab Improper readonly query validation allows unauthorized write access
Published · Updated
E-mail alert when it lands in KEV, gets a public PoC or its score goes up.
21Vexday Risk Score
No sign of exploitation. No public exploitation artifact known so far.
ssvc Trackcvss 7.1epss 2.8%
Improper Authorization vulnerability in Apache Superset. On Postgres analytic databases an attacker with SQLLab access can craft a specially designed SQL DML statement that is Incorrectly identified as a read-only query, enabling its execution. Non postgres analytics database connections and postgres analytics database connections set with a readonly user (advised) are not vulnerable.
This issue affects Apache Superset: before 4.1.0.
Users are recommended to upgrade to version 4.1.0, which fixes the issue.
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N
Affected products
Apache Software Foundation · Apache SupersetRelated CVEs — Apache Superset
In the same product, most dangerous first.
CVE-2023-27524HIGHApache Superset: Session validation vulnerability when using provided default SECRET_KEYEPSS 98.1%KEVCVE-2021-27907—Apache Superset stored XSS on Dashboard markdownEPSS 86.4%CVE-2023-39265LOWApache Superset: Possible Unauthorized Registration of SQLite Database ConnectionsEPSS 86.0%CVE-2021-28125—Apache Superset Open RedirectEPSS 64.0%CVE-2023-37941MEDIUMApache Superset: Metadata db write access can lead to remote code executionEPSS 35.5%CVE-2021-44451—API sensitive information leakEPSS 7.9%