CVE-2024-6751: medium-severity vulnerability in WPWeb Social Auto Poster
Social Auto Poster <= 5.3.14 - Cross-Site Request Forgery via Multiple Functions
Published · Updated
E-mail alert when it lands in KEV, gets a public PoC or its score goes up.
13Vexday Risk Score
No sign of exploitation. No public exploitation artifact known so far.
ssvc Trackcvss 6.3epss 0.2%
The Social Auto Poster plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 5.3.14. This is due to missing or incorrect nonce validation on multiple functions. This makes it possible for unauthenticated attackers to add, modify, or delete post meta and plugin options.
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L
Affected products
WPWeb · Social Auto PosterRelated CVEs — WPWeb Social Auto Poster
In the same product, most dangerous first.
CVE-2024-6753HIGHSocial Auto Poster <= 5.3.14 - Unauthenticated Stored Cross-Site ScriptingEPSS 0.8%CVE-2024-6756HIGHSocial Auto Poster <= 5.3.14 - Authenticated (Contributor+) Arbitrary File UploadEPSS 0.8%CVE-2024-6755MEDIUMSocial Auto Poster <= 5.3.14 - Missing Authorization to Unauthenticated Arbitrary Post DeletionEPSS 0.3%CVE-2024-6750HIGHSocial Auto Poster <= 5.3.14 - Missing Authorization via Multiple FunctionsEPSS 0.3%CVE-2024-6754MEDIUMSocial Auto Poster <= 5.3.14 - Missing Authorization to Authenticated (Subscriber+) Arbitrary Post Meta Update via wpw_auto_poster_update_tweet_templateEPSS 0.3%CVE-2024-6752MEDIUMSocial Auto Poster <= 5.3.14 - Authenticated (Subscriber+) Stored Cross-Site ScriptingEPSS 0.3%