CVE-2025-12358: medium-severity vulnerability in roxnor ShopEngine Elementor WooCommerce…
ShopEngine <= 4.8.5 - Cross-Site Request Forgery to Wishlist Manipulation
Published · Updated
Follow this CVE+ Monitor ShopEngine Elementor WooCommerce Builder Addon – All in One WooCommerce Solution
E-mail alert when it lands in KEV, gets a public PoC or its score goes up.
13Vexday Risk Score
No sign of exploitation. No public exploitation artifact known so far.
ssvc Trackcvss 4.3epss 0.1%
The ShopEngine Elementor WooCommerce Builder Addon plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 4.8.5. This is due to missing nonce validation on the "post_add_to_list" function as well as an incorrect permissions callback in the "Api/init" function. This makes it possible for unauthenticated attackers to add or remove products from a user's wishlist via a forged request granted they can trick a site's user into performing an action such as clicking on a link.
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
Affected products
roxnor · ShopEngine Elementor WooCommerce Builder Addon – All in One WooCommerce SolutionRelated CVEs — roxnor ShopEngine Elementor WooCommerce…
In the same product, most dangerous first.
CVE-2025-11888LOWShopEngine Elementor WooCommerce Builder Addon – All in One WooCommerce Solution <= 4.8.4 - Incorrect Authorization to Authenticated (Editor+) License Status UpdateEPSS 0.2%CVE-2025-10173LOWShopEngine Elementor WooCommerce Builder Addon – All in One WooCommerce Solution <= 4.8.3 - Insufficient Authorization to Authenticated (Editor+) Settings UpdateEPSS 0.2%