CVE-2025-14448: medium-severity vulnerability in cbutlerjr WP-Members Membership Plugin
WP-Members Membership Plugin <= 3.5.4.3 - Authenticated (Subscriber+) Stored Cross-Site Scripting via Multiple Checkbox and Multiple Select User Profile Fields
Published · Updated
E-mail alert when it lands in KEV, gets a public PoC or its score goes up.
13Vexday Risk Score
No sign of exploitation. No public exploitation artifact known so far.
ssvc Trackcvss 5.4epss 0.2%
The WP-Members Membership Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Multiple Checkbox and Multiple Select user profile fields in all versions up to, and including, 3.5.4.3 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Affected products
cbutlerjr · WP-Members Membership PluginRelated CVEs — cbutlerjr WP-Members Membership Plugin
In the same product, most dangerous first.
CVE-2024-1852HIGHWP-Members Membership Plugin <= 3.4.9.2 - Unauthenticated Stored Cross-Site ScriptingEPSS 0.7%CVE-2023-2869MEDIUMWP-Members Membership <= 3.4.7.3 - Missing Authorization to Settings UpdateEPSS 0.5%CVE-2024-2920MEDIUMWP-Members Membership Plugin <= 3.4.9.3 - Unprotected Storage of Potentially Sensitive FilesEPSS 0.5%CVE-2024-9231MEDIUMWP-Members Membership Plugin <= 3.4.9.5 - Reflected Cross-Site ScriptingEPSS 0.5%CVE-2024-10374MEDIUMWP-Members <= 3.4.9.5 - Authenticated (Contributor+) Stored Cross-Site Scripting via wpmem_loginout ShortcodeEPSS 0.4%CVE-2023-6733MEDIUMWP-Members Membership Plugin <= 3.4.8 - Missing Authorization to Sensitive Information ExposureEPSS 0.4%