CVE-2025-15033: medium-severity vulnerability in Automattic WooCommerce
WooCommerce - Subscriber/Customer+ Order Data Disclosure
Published · Updated
E-mail alert when it lands in KEV, gets a public PoC or its score goes up.
13Vexday Risk Score
No sign of exploitation. No public exploitation artifact known so far.
ssvc Trackcvss 6.5epss 0.3%
A vulnerability in WooCommerce 8.1 to 10.4.2 can allow logged-in customers to access order data of guest customers on sites with a certain configuration. This has been fixed in WooCommerce 10.4.3, as well as all the previously affected versions through point releases, starting from 8.1, where it has been fixed in 8.1.3. It does not affect WooCommerce 8.0 or earlier.
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Affected products
Automattic · WooCommerceRelated CVEs — Automattic WooCommerce
In the same product, most dangerous first.
CVE-2023-47777MEDIUMWordPress WooCommerce and WooCommerce Blocks plugins - Auth. Cross-Site Scripting (XSS) vulnerabilityEPSS 0.8%CVE-2021-24323—Woocommerce < 5.2.0 - Authenticated Stored Cross-Site Scripting (XSS)EPSS 0.7%CVE-2026-48888HIGHWordPress WooCommerce plugin < 11.1.0 - Denial of Service Attack vulnerabilityEPSS 0.5%CVE-2026-57777HIGHWordPress WooCommerce plugin < 11.0 - SQL Injection vulnerabilityEPSS 0.4%CVE-2024-39666MEDIUMWordPress WooCommerce plugin <= 9.1.2 - Cross Site Scripting (XSS) vulnerabilityEPSS 0.4%CVE-2024-35777LOWWordPress WooCommerce plugin <= 8.9.2 - Content Injection vulnerabilityEPSS 0.4%