CVE-2025-54988highobserved exploitationCWE-611

CVE-2025-54988: high-severity vulnerability in Apache Tika PDF parser module

Apache Tika PDF parser module: XXE vulnerability in PDFParser's handling of XFA

Published · Updated

E-mail alert when it lands in KEV, gets a public PoC or its score goes up.

90Vexday Risk Score

Patch now. It exploitation observed by VulnCheck and has a working public exploit.

ssvc Actcvss 8.4epss 48%
from disclosure to weapon15 days
Published on NVDAug 20
1st PoC+15d
metasploitAug 20
VulnCheck+434d
Critical XXE in Apache Tika (tika-parser-pdf-module) in Apache Tika 1.13 through and including 3.2.1 on all platforms allows an attacker to carry out XML External Entity injection via a crafted XFA file inside of a PDF. An attacker may be able to read sensitive data or trigger malicious requests to internal resources or third-party servers. Note that the tika-parser-pdf-module is used as a dependency in several Tika packages including at least: tika-parsers-standard-modules, tika-parsers-standard-package, tika-app, tika-grpc and tika-server-standard. Users are recommended to upgrade to version 3.2.2, which fixes this issue.
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
⚠ Public resources, to assess the exposure of systems you control or are authorized to test. Test only with authorization.