CVE-2026-116675: high-severity vulnerability in tinymce
TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` serialization
Published · Updated
21Vexday Risk Score
No sign of exploitation. No public exploitation artifact known so far.
ssvc Trackcvss 8.5epss 0.3%
exploitation probability
0.3%top 72% of all CVEs
observed exploitation
nono source reports it
TinyMCE is an open source rich text editor. From 7.9.3 until 7.9.4 and from 8.5.1 until 8.9.3, the media plugin creates elements crafted through data-mce-object in the active document before sanitization. Those elements can execute malicious scripts during processing, resulting in stored cross-site scripting for users with the media plugin enabled. This issue is fixed in versions 8.9.3 and 7.9.4.
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
Affected products
tinymce · tinymceRelated CVEs — tinymce
In the same product, most dangerous first.
CVE-2019-1010091—CVE-2019-1010091EPSS 1.9%CVE-2022-23494MEDIUMCross-site scripting vulnerability in TinyMCE alertsEPSS 1.0%CVE-2023-45818MEDIUMCross-site Scripting vulnerability in TinyMCE undo/redo, getContent API, resetContent API, and Autosave pluginEPSS 0.8%CVE-2023-48219MEDIUMSpecial characters in unescaped text nodes can trigger mXSS in TinyMCEEPSS 0.7%CVE-2024-29881MEDIUMTinyMCE Cross-Site Scripting (XSS) vulnerability in handling external SVG files through Object or Embed elementsEPSS 0.7%CVE-2024-29203MEDIUMTinyMCE Cross-Site Scripting (XSS) vulnerability in handling iframesEPSS 0.7%
References
https://github.com/tinymce/tinymce/commit/bd1ab5ef024c648c3f9c0b409e54a6c227c7d8a2https://github.com/tinymce/tinymce/releases/tag/8.9.3https://github.com/tinymce/tinymce/security/advisories/GHSA-mf2p-h6hf-fcwmhttps://www.tiny.cloud/docs/tinymce/7/7.9.4-release-notes/#overviewhttps://www.tiny.cloud/docs/tinymce/latest/8.9.3-release-notes/#overview