CVE-2026-120597: medium-severity vulnerability in Welcart e-Commerce Plugin
Welcart e-Commerce Plugin paymentESCOTT.main.class.php error_page_message cross site scripting
Published · Updated
E-mail alert when it lands in KEV, gets a public PoC or its score goes up.
33Vexday Risk Score
No sign of exploitation. It has a public proof of concept.
ssvc Attendcvss 5.3epss 0.3%
A vulnerability was identified in Welcart e-Commerce Plugin up to 2.12.6 on WordPress. This affects the function ESCOTT_MAIN::error_page_message of the file classes/paymentESCOTT.main.class.php. Such manipulation of the argument ResponseCd leads to cross site scripting. The attack can be launched remotely. The exploit is publicly available and might be used. Upgrading to version 2.12.7 mitigates this issue. It is recommended to upgrade the affected component. The value is now escaped with esc_html() before output. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P
Affected products
Welcart · e-Commerce Pluginpublic PoCs found — 1
cve_referencegithub.com/bevennyamande/welcart-pocunverified⚠ Public resources, to assess the exposure of systems you control or are authorized to test. Test only with authorization.