CVE-2026-27124: high-severity vulnerability in jlowin fastmcp
FastMCP: Missing Consent Verification in OAuth Proxy Callback Facilitates Confused Deputy Vulnerabilities
Published
E-mail alert when it lands in KEV, gets a public PoC or its score goes up.
21Vexday Risk Score
No sign of exploitation. No public exploitation artifact known so far.
ssvc Trackcvss 8.2epss 0.2%
FastMCP is the standard framework for building MCP applications. Prior to version 3.2.0, while testing the GitHubProvider OAuth integration, which allows authentication to a FastMCP MCP server via a FastMCP OAuthProxy using GitHub OAuth, it was discovered that the FastMCP OAuthProxy does not properly validate the user's consent upon receiving the authorization code from GitHub. In combination with GitHub’s behavior of skipping the consent page for previously authorized clients, this introduces a Confused Deputy vulnerability. This issue has been patched in version 3.2.0.
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N
Affected products
jlowin · fastmcpRelated CVEs — jlowin fastmcp
In the same product, most dangerous first.
CVE-2025-64340MEDIUMFastMCP has a Command Injection vulnerability - Gemini CLIEPSS 0.7%CVE-2025-69196HIGHFastMCP OAuth Proxy token reuse across MCP serversEPSS 0.4%CVE-2025-62800MEDIUMFastMCP vulnerable to reflected XSS in client's callback pageEPSS 0.3%CVE-2025-62801MEDIUMFastMCP vulnerable to windows command injection in FastMCP Cursor installer via server_nameEPSS 0.2%