CVE-2026-44160: high-severity vulnerability in fluentd
Fluentd: Denial of Service (DoS) via Gzip Decompression Bomb in `in_http` and `in_forward`
Published · Updated
E-mail alert when it lands in KEV, gets a public PoC or its score goes up.
21Vexday Risk Score
No sign of exploitation. No public exploitation artifact known so far.
ssvc Trackcvss 7.5epss 0.6%
Fluentd collects events from various data sources and writes them to files, RDBMS, NoSQL, IaaS, SaaS, Hadoop and so on. Prior to 1.19.3, Fluentd's in_http and in_forward plugins support gzip-compressed data but enforce limits only on compressed payloads through settings such as body_size_limit and chunk_size_limit, allowing crafted compressed payloads to decompress in memory to an excessive size and cause denial of service through memory exhaustion. This issue is fixed in version 1.19.3.
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Affected products
fluent · fluentdRelated CVEs — fluentd
In the same product, most dangerous first.
CVE-2022-39379LOWFluentd vulnerable to remote code execution due to insecure deserialization (in non-default configuration)EPSS 45.0%CVE-2021-41186MEDIUMReDoS vulnerability in parser_apache2EPSS 2.2%CVE-2026-44024CRITICALFluentd: Remote Code Execution (RCE) via Arbitrary File Write in `${tag}` PlaceholderEPSS 1.1%CVE-2026-44025HIGHFluentd: Exposure of Sensitive Information via Monitor Agent APIEPSS 0.5%CVE-2026-44161HIGHFluentd: Server-Side Request Forgery (SSRF) via Placeholder Expansion in `out_http`EPSS 0.4%