CVE-2026-75020: high-severity vulnerability in Apache APISIX
Apache APISIX: ldap-auth plugin cross-subtree identity impersonation
Published
E-mail alert when it lands in KEV, gets a public PoC or its score goes up.
21Vexday Risk Score
No sign of exploitation. No public exploitation artifact known so far.
ssvc Trackcvss 7epss 0.5%
Improper Neutralization of Special Elements used in an LDAP Query ('LDAP Injection') vulnerability in Apache APISIX.
A caller who holds valid credentials for one entry in the LDAP directory can authenticate through APISIX as a consumer mapped to a different entry, one the plugin's configured scope was meant to keep out of reach.
This issue affects Apache APISIX: from 2.11.0 through 3.17.0.
Users are recommended to upgrade to version 3.18.0, which fixes the issue.
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N
Affected products
Apache Software Foundation · Apache APISIXRelated CVEs — Apache APISIX
In the same product, most dangerous first.
CVE-2022-24112CRITICALapisix/batch-requests plugin allows overwriting the X-REAL-IP headerEPSS 96.1%KEVCVE-2020-13945—CVE-2020-13945EPSS 73.0%CVE-2021-43557—Path traversal in request_uri variableEPSS 13.0%CVE-2022-29266—apisix/jwt-auth may leak secrets in error responseEPSS 8.1%CVE-2022-25757—Apache APISIX: the body_schema check in request-validation plugin can be bypassedEPSS 2.5%CVE-2024-32638MEDIUMApache APISIX: Forward-Auth Request SmugglingEPSS 1.1%