CVE-2026-77078highCWE-248

CVE-2026-77078: high-severity vulnerability in multer

multer vulnerable to Denial of Service via crafted multipart field names

Published · Updated

E-mail alert when it lands in KEV, gets a public PoC or its score goes up.

41Vexday Risk Score

No sign of exploitation. It has a public proof of concept.

ssvc Attendcvss 7.5epss 0.5%
from disclosure to weapon24 days
Published on NVDAug 28
1st PoC+24d
multer is a middleware for handling multipart/form-data in Node.js. A small multipart request containing two specially crafted text field names can cause an uncaught RangeError (Invalid array length) that terminates the Node.js process. The first field uses a very large numeric array index to allocate a maximum-length sparse array, and a second field then pushes past that length, which throws inside the append-field dependency and is not caught by multer. All versions before 2.3.0 are affected, and the issue is a remotely triggerable denial of service. The issue is fixed in multer 2.3.0. Upgrade to multer 2.3.0 to remediate.
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Affected products
multer · multer
⚠ Public resources, to assess the exposure of systems you control or are authorized to test. Test only with authorization.