CVE-2023-25564: falha de média gravidade em gssapi gss-ntlmssp
GSS-NTLMSSP vulnerable to memory corruption when decoding UTF16 strings
Publicada em · Atualizada em
Aviso por e-mail quando ela entrar no KEV, ganhar PoC pública ou subir de nota.
13Vexday Risk Score
Sem sinal de exploração. Nenhum artefato público de exploração conhecido até agora.
ssvc Trackcvss 6.5epss 1.9%
GSS-NTLMSSP is a mechglue plugin for the GSSAPI library that implements NTLM authentication. Prior to version 1.2.0, memory corruption can be triggered when decoding UTF16 strings. The variable `outlen` was not initialized and could cause writing a zero to an arbitrary place in memory if `ntlm_str_convert()` were to fail, which would leave `outlen` uninitialized. This can lead to a denial of service if the write hits unmapped memory or randomly corrupts a byte in the application memory space. This vulnerability can trigger an out-of-bounds write, leading to memory corruption. This vulnerability can be triggered via the main `gss_accept_sec_context` entry point. This issue is fixed in version 1.2.0.
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:H
Produtos afetados
gssapi · gss-ntlmsspCVEs relacionadas — gssapi gss-ntlmssp
No mesmo produto, das mais perigosas para as menos.
CVE-2023-25567HIGHGSS-NTLMSSP vulnerable to out-of-bounds read when decoding target informationEPSS 1.1%CVE-2023-25566HIGHGSS-NTLMSSP vulnerable to memory leak when parsing usernamesEPSS 1.1%CVE-2023-25565HIGHGSS-NTLMSSP vulnerable to incorrect free when decoding target informationEPSS 1.1%CVE-2023-25563MEDIUMGSS-NTLMSSP vulnerable to multiple out-of-bounds reads when decoding NTLM fieldsEPSS 1.1%