CVE-2023-25567: falha de alta gravidade em gssapi gss-ntlmssp
GSS-NTLMSSP vulnerable to out-of-bounds read when decoding target information
Publicada em · Atualizada em
Aviso por e-mail quando ela entrar no KEV, ganhar PoC pública ou subir de nota.
21Vexday Risk Score
Sem sinal de exploração. Nenhum artefato público de exploração conhecido até agora.
ssvc Trackcvss 7.5epss 1.1%
GSS-NTLMSSP, a mechglue plugin for the GSSAPI library that implements NTLM authentication, has an out-of-bounds read when decoding target information prior to version 1.2.0. The length of the `av_pair` is not checked properly for two of the elements which can trigger an out-of-bound read. The out-of-bounds read can be triggered via the main `gss_accept_sec_context` entry point and could cause a denial-of-service if the memory is unmapped. The issue is fixed in version 1.2.0.
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Produtos afetados
gssapi · gss-ntlmsspCVEs relacionadas — gssapi gss-ntlmssp
No mesmo produto, das mais perigosas para as menos.
CVE-2023-25564MEDIUMGSS-NTLMSSP vulnerable to memory corruption when decoding UTF16 stringsEPSS 1.9%CVE-2023-25566HIGHGSS-NTLMSSP vulnerable to memory leak when parsing usernamesEPSS 1.1%CVE-2023-25565HIGHGSS-NTLMSSP vulnerable to incorrect free when decoding target informationEPSS 1.1%CVE-2023-25563MEDIUMGSS-NTLMSSP vulnerable to multiple out-of-bounds reads when decoding NTLM fieldsEPSS 1.1%