CVE-2024-3211: high-severity vulnerability in levelfourstorefront Shopping Cart & eCommerce…
Shopping Cart & eCommerce Store <= 5.6.3 - Authenticated (Contributor+) SQL Injection
Published · Updated
E-mail alert when it lands in KEV, gets a public PoC or its score goes up.
21Vexday Risk Score
No sign of exploitation. No public exploitation artifact known so far.
ssvc Trackcvss 8.8epss 0.6%
The Shopping Cart & eCommerce Store plugin for WordPress is vulnerable to SQL Injection via the 'productid' attribute of the ec_addtocart shortcode in all versions up to, and including, 5.6.3 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with contributor-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Affected products
levelfourstorefront · Shopping Cart & eCommerce StoreRelated CVEs — levelfourstorefront Shopping Cart & eCommerce…
In the same product, most dangerous first.
CVE-2023-3023HIGHWP EasyCart <= 5.4.10 - Authenticated (Administrator+) SQL Injection via 'orderby'EPSS 0.7%CVE-2026-17553HIGHShopping Cart & eCommerce Store <= 5.9.3 - Authenticated (Store Manager+) Privilege Escalation to ec_ajax_save_page_default_options AJAX ActionEPSS 0.6%CVE-2024-7827HIGHShopping Cart & eCommerce Store <= 5.7.2 - Authenticated (Contributor+) SQL Injection via model_number ParameterEPSS 0.5%CVE-2024-4213MEDIUMShopping Cart & eCommerce Store <= 5.6.4 - Sensitive Information ExposureEPSS 0.5%CVE-2026-17589MEDIUMShopping Cart & eCommerce Store <= 5.9.2 - Authenticated (Administrator+) SQL Injection via 'product_order' ParameterEPSS 0.5%CVE-2024-12712MEDIUMShopping Cart & eCommerce Store <= 5.7.8 - Missing Authorization to Order UpdatesEPSS 0.4%