CVE-2026-17589: medium-severity vulnerability in levelfourstorefront Shopping Cart & eCommerce…
Shopping Cart & eCommerce Store <= 5.9.2 - Authenticated (Administrator+) SQL Injection via 'product_order' Parameter
Published
E-mail alert when it lands in KEV, gets a public PoC or its score goes up.
13Vexday Risk Score
No sign of exploitation. No public exploitation artifact known so far.
ssvc Trackcvss 4.9epss 0.5%
The Shopping Cart & eCommerce Store plugin for WordPress is vulnerable to generic SQL Injection via the 'product_order' parameter in all versions up to, and including, 5.9.2 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with administrator-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database. This is a second-order SQL injection: the payload is written to the ec_pageoption table via the ec_ajax_save_page_options handler — which applies no sanitization to raw $_POST values — and is later retrieved with stripslashes() (bypassing WordPress magic-quotes protection) before being concatenated directly into SQL on every store page render.
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
Affected products
levelfourstorefront · Shopping Cart & eCommerce StoreRelated CVEs — levelfourstorefront Shopping Cart & eCommerce…
In the same product, most dangerous first.
CVE-2023-3023HIGHWP EasyCart <= 5.4.10 - Authenticated (Administrator+) SQL Injection via 'orderby'EPSS 0.7%CVE-2026-17553HIGHShopping Cart & eCommerce Store <= 5.9.3 - Authenticated (Store Manager+) Privilege Escalation to ec_ajax_save_page_default_options AJAX ActionEPSS 0.6%CVE-2024-3211HIGHShopping Cart & eCommerce Store <= 5.6.3 - Authenticated (Contributor+) SQL InjectionEPSS 0.6%CVE-2024-7827HIGHShopping Cart & eCommerce Store <= 5.7.2 - Authenticated (Contributor+) SQL Injection via model_number ParameterEPSS 0.5%CVE-2024-4213MEDIUMShopping Cart & eCommerce Store <= 5.6.4 - Sensitive Information ExposureEPSS 0.5%CVE-2024-12712MEDIUMShopping Cart & eCommerce Store <= 5.7.8 - Missing Authorization to Order UpdatesEPSS 0.4%
References
https://plugins.trac.wordpress.org/browser/wp-easycart/tags/5.9.1/inc/classes/store/ec_filter.php#L768https://plugins.trac.wordpress.org/browser/wp-easycart/tags/5.9.1/wpeasycart.php#L7086https://plugins.trac.wordpress.org/browser/wp-easycart/tags/5.9.1/wpeasycart.php#L7181https://plugins.trac.wordpress.org/changeset?reponame=&old=3659459%40wp-easycart&new=3659459%40wp-easycarthttps://www.wordfence.com/threat-intel/vulnerabilities/id/22e284d3-1ccc-47e4-9e98-c7a38b97446b?source=cve