CVE-2025-49506: fallo de gravedad alta en Apache Portable Runtime Utility
Apache Portable Runtime Utility: apr_password_validate() vulnerable to timing attack
Publicada el
Aviso por correo cuando entre en el KEV, tenga PoC pública o suba de nota.
21Vexday Risk Score
Sin señal de explotación. Ningún artefacto público de explotación conocido hasta ahora.
ssvc Trackcvss 7.5epss 0.4%
APR-util versions 1.6.3 (and earlier) function apr_password_validate() was not constant-time with regards to hashes or passwords comparisons, potentially leaking their content via a side channel timing attack particularly on platforms without crypt() such as Windows, BeOS, NetWare, or Android.
Users are recommended to upgrade to version 1.6.4, which fixes this issue.
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Productos afectados
Apache Software Foundation · Apache Portable Runtime UtilityCVEs relacionadas — Apache Portable Runtime Utility
En el mismo producto, de las más peligrosas a las menos.
CVE-2026-34191CRITICALApache Portable Runtime Utility: SQL Injection in apr_dbd_oracleEPSS 0.6%CVE-2026-34501HIGHApache Portable Runtime Utility: Heap buffer overflow in APR redis clientEPSS 0.5%CVE-2026-34502HIGHApache Portable Runtime Utility: Heap buffer overflow in APR memcached clientEPSS 0.5%CVE-2026-32327CRITICALApache Portable Runtime Utility: apr-util XML stack recursion crashEPSS 0.5%