CVE-2025-49506: high-severity vulnerability in Apache Portable Runtime Utility
Apache Portable Runtime Utility: apr_password_validate() vulnerable to timing attack
Published
E-mail alert when it lands in KEV, gets a public PoC or its score goes up.
21Vexday Risk Score
No sign of exploitation. No public exploitation artifact known so far.
ssvc Trackcvss 7.5epss 0.4%
APR-util versions 1.6.3 (and earlier) function apr_password_validate() was not constant-time with regards to hashes or passwords comparisons, potentially leaking their content via a side channel timing attack particularly on platforms without crypt() such as Windows, BeOS, NetWare, or Android.
Users are recommended to upgrade to version 1.6.4, which fixes this issue.
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Affected products
Apache Software Foundation · Apache Portable Runtime UtilityRelated CVEs — Apache Portable Runtime Utility
In the same product, most dangerous first.
CVE-2026-34191CRITICALApache Portable Runtime Utility: SQL Injection in apr_dbd_oracleEPSS 0.6%CVE-2026-34501HIGHApache Portable Runtime Utility: Heap buffer overflow in APR redis clientEPSS 0.5%CVE-2026-34502HIGHApache Portable Runtime Utility: Heap buffer overflow in APR memcached clientEPSS 0.5%CVE-2026-32327CRITICALApache Portable Runtime Utility: apr-util XML stack recursion crashEPSS 0.5%