CVE-2025-49506: falha de alta gravidade em Apache Portable Runtime Utility
Apache Portable Runtime Utility: apr_password_validate() vulnerable to timing attack
Publicada em
Aviso por e-mail quando ela entrar no KEV, ganhar PoC pública ou subir de nota.
21Vexday Risk Score
Sem sinal de exploração. Nenhum artefato público de exploração conhecido até agora.
ssvc Trackcvss 7.5epss 0.4%
APR-util versions 1.6.3 (and earlier) function apr_password_validate() was not constant-time with regards to hashes or passwords comparisons, potentially leaking their content via a side channel timing attack particularly on platforms without crypt() such as Windows, BeOS, NetWare, or Android.
Users are recommended to upgrade to version 1.6.4, which fixes this issue.
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Produtos afetados
Apache Software Foundation · Apache Portable Runtime UtilityCVEs relacionadas — Apache Portable Runtime Utility
No mesmo produto, das mais perigosas para as menos.
CVE-2026-34191CRITICALApache Portable Runtime Utility: SQL Injection in apr_dbd_oracleEPSS 0.6%CVE-2026-34501HIGHApache Portable Runtime Utility: Heap buffer overflow in APR redis clientEPSS 0.5%CVE-2026-34502HIGHApache Portable Runtime Utility: Heap buffer overflow in APR memcached clientEPSS 0.5%CVE-2026-32327CRITICALApache Portable Runtime Utility: apr-util XML stack recursion crashEPSS 0.5%